Bug 470629 - gnome-sound-recorder CPU and RAM usage climbs after clicking Record and then locks up after clicking Stop.
gnome-sound-recorder CPU and RAM usage climbs after clicking Record and then ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
10
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 21:44 EST by Gideon Mayhak
Modified: 2009-04-22 22:35 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-22 22:35:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example "audio file" created by gnome-sound-recorder (12.00 KB, application/octet-stream)
2008-11-07 21:44 EST, Gideon Mayhak
no flags Details

  None (edit)
Description Gideon Mayhak 2008-11-07 21:44:11 EST
Created attachment 322924 [details]
Example "audio file" created by gnome-sound-recorder

Description of problem:
When I open gnome-sound-recorder and click Record, the Duration value jumps up to a very high value very quickly (like 40 minutes after 5 seconds of "recording").  CPU usage is very high, and RAM usage climbs (was over 250MB within a few seconds).  Clicking Stop locks up the program and I have to Force Quit.  It creates a file in the /tmp folder, but it's only a few KB in size.  Opening file properties and clicking the Audio tab shows a duration similar to what was shown in the gnome-sound-recorder interface.


Version-Release number of selected component (if applicable):
gnome-media.x86_64                   2.24.0.1-2.fc10


How reproducible:
Every time.


Steps to Reproduce:
1. Open gnome-sound-recorder
2. Click Record
3. Watch duration climb and click Stop
4. Click X to close windows and Force Quit
  
Actual results:
Program locks up, records nothing, and creates a 4-16KB file in /tmp.


Expected results:
Record audio normally and allow me to stop and save file.


Additional info:
Output when run from a terminal:

[gideon@gidux-laptop-rawhide ~]$ gnome-sound-recorder

(gnome-sound-recorder:4034): Gtk-CRITICAL **: gtk_widget_get_accessible: assertion `GTK_IS_WIDGET (widget)' failed

** (gnome-sound-recorder:4034): CRITICAL **: atk_object_add_relationship: assertion `ATK_IS_OBJECT (target)' failed
/tmp/gsr-record-Untitled-4034.6WL3JUKilled

I don't have much installed beyond a default DVD install.  One thing of note is that I have some i386 components installed for flash-plugin compatibility.  Here's the list of currently installed i386 packages:

[gideon@gidux-laptop-rawhide ~]$ yum list installed | grep i386
adobe-release-i386.noarch                  1.0-1                       installed
alsa-lib.i386                              1.0.18-6.rc3.fc10           installed
atk.i386                                   1.24.0-1.fc10               installed
cairo.i386                                 1.8.0-1.fc10                installed
cups-libs.i386                             1:1.3.9-2.fc10              installed
cyrus-sasl-lib.i386                        2.1.22-19.fc10              installed
db4.i386                                   4.7.25-5.fc10               installed
dbus-libs.i386                             1.2.4-1.fc10                installed
e2fsprogs-libs.i386                        1.41.3-1.fc10               installed
expat.i386                                 2.0.1-5                     installed
flac.i386                                  1.2.1-4.fc9                 installed
flash-plugin.i386                          10.0.12.36-release          installed
fontconfig.i386                            2.6.0-3.fc10                installed
freetype.i386                              2.3.7-1.fc10                installed
gamin.i386                                 0.1.9-6.fc10                installed
gdbm.i386                                  1.8.0-29.fc10               installed
glib2.i386                                 2.18.2-3.fc10               installed
glibc.i386                                 2.8.90-16                   installed
gnutls.i386                                2.4.2-2.fc10                installed
gtk2.i386                                  2.14.4-3.fc10               installed
jasper-libs.i386                           1.900.1-8.fc9               installed
keyutils-libs.i386                         1.2-3.fc9                   installed
krb5-libs.i386                             1.6.3-16.fc10               installed
lcms-libs.i386                             1.17-6.fc10                 installed
libICE.i386                                1.0.4-4.fc10                installed
libSM.i386                                 1.1.0-2.fc10                installed
libX11.i386                                1.1.4-5.fc10                installed
libXScrnSaver.i386                         1.1.3-1.fc10                installed
libXau.i386                                1.0.4-1.fc10                installed
libXcomposite.i386                         0.4.0-5.fc10                installed
libXcursor.i386                            1.1.9-3.fc10                installed
libXdamage.i386                            1.1.1-4.fc9                 installed
libXdmcp.i386                              1.0.2-6.fc10                installed
libXext.i386                               1.0.4-1.fc9                 installed
libXfixes.i386                             4.0.3-4.fc10                installed
libXft.i386                                2.1.13-1.fc10               installed
libXi.i386                                 1.1.3-4.fc9                 installed
libXinerama.i386                           1.0.3-2.fc10                installed
libXrandr.i386                             1.2.3-1.fc10                installed
libXrender.i386                            0.9.4-3.fc9                 installed
libXt.i386                                 1.0.5-1.fc10                installed
libXv.i386                                 1.0.4-1.fc10                installed
libXxf86vm.i386                            1.0.2-1.fc10                installed
libasyncns.i386                            0.7-1.fc10                  installed
libcap.i386                                2.10-2.fc10                 installed
libcurl.i386                               7.18.2-7.fc10               installed
libdrm.i386                                2.4.0-0.21.fc10             installed
libgcc.i386                                4.3.2-7                     installed
libgcrypt.i386                             1.4.3-2.fc10                installed
libgpg-error.i386                          1.6-2                       installed
libidn.i386                                0.6.14-8                    installed
libjpeg.i386                               6b-43.fc10                  installed
libmng.i386                                1.0.9-7                     installed
libogg.i386                                2:1.1.3-9.fc9               installed
liboil.i386                                0.3.14-1.fc9                installed
libpng.i386                                2:1.2.31-2.fc10             installed
libsamplerate.i386                         0.1.4-1.fc10                installed
libselinux.i386                            2.0.73-1.fc10               installed
libsndfile.i386                            1.0.17-6.fc10               installed
libssh2.i386                               0.18-7.fc9                  installed
libstdc++.i386                             4.3.2-7                     installed
libtasn1.i386                              1.5-1.fc10                  installed
libthai.i386                               0.1.9-4.fc9                 installed
libtiff.i386                               3.8.2-11.fc10               installed
libtool-ltdl.i386                          1.5.26-4.fc10               installed
libxcb.i386                                1.1.91-5.fc10               installed
mesa-libGL.i386                            7.2-0.13.fc10               installed
mesa-libGLU.i386                           7.2-0.13.fc10               installed
ncurses-libs.i386                          5.6-20.20080927.fc10        installed
nspluginwrapper.i386                       1.1.2-4.fc10                installed
nspr.i386                                  4.7.2-2.fc10                installed
nss.i386                                   3.12.2.0-3.fc10             installed
openldap.i386                              2.4.12-1.fc10               installed
openssl.i386                               0.9.8g-11.fc10              installed
pango.i386                                 1.22.1-1.fc10               installed
pixman.i386                                0.12.0-1.fc10               installed
pulseaudio-core-libs.i386                  0.9.13-6.fc10               installed
pulseaudio-libs.i386                       0.9.13-6.fc10               installed
qt.i386                                    1:4.4.3-1.fc10              installed
qt-x11.i386                                1:4.4.3-1.fc10              installed
readline.i386                              5.2-13.fc9                  installed
speex.i386                                 1.2-0.10.rc1.fc10           installed
sqlite.i386                                3.5.9-2.fc10                installed
zlib.i386                                  1.2.3-18.fc9                installed
Comment 1 Tom London 2008-11-11 13:17:25 EST
I can verfiy that I am seeing this as well on Rawhide x86_64 system (Thinkpad X61).

I see the following in ~/.xsession-errors:

(gnome-sound-recorder:4018): Gtk-CRITICAL **: gtk_widget_get_accessible: assertion `GTK_IS_WIDGET (widget)' failed

** (gnome-sound-recorder:4018): CRITICAL **: atk_object_add_relationship: assertion `ATK_IS_OBJECT (target)' failed
/tmp/gsr-record-Untitled-4018.4H9AKU
Comment 2 antonio montagnani 2008-11-11 14:23:05 EST
This is what I get when I try to record:

(gnome-sound-recorder:3190): GStreamer-CRITICAL **: gst_implements_interface_cast: assertion `gst_element_implements_interface (GST_ELEMENT (from), iface_type)' failed

(gnome-sound-recorder:3190): Gtk-CRITICAL **: gtk_widget_get_accessible: assertion `GTK_IS_WIDGET (widget)' failed

** (gnome-sound-recorder:3190): CRITICAL **: atk_object_add_relationship: assertion `ATK_IS_OBJECT (target)' failed
/tmp/gsr-record-Senza nome-3190.EO57JU
(gnome-sound-recorder:3190): GStreamer-CRITICAL **: gst_tag_list_foreach: assertion `GST_IS_TAG_LIST (list)' failed

(gnome-sound-recorder:3190): GStreamer-CRITICAL **: gst_event_new_tag: assertion `taglist != NULL' failed

(gnome-sound-recorder:3190): GStreamer-CRITICAL **: gst_pad_push_event: assertion `event != NULL' failed
Comment 3 Gianluca Sforna 2008-11-11 16:30:46 EST
Mee too, on a x86 system
Comment 4 TK009 2008-11-25 08:31:53 EST
This bug has been triaged
Comment 5 Bug Zapper 2008-11-26 00:01:39 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Pedro Matiello 2008-11-30 14:53:32 EST
Same issue. Changing sound capture source to Pulseaudio in Sound Preferences enables recording for me, but the sound is full of crack-like noises if Rhythmbox has played some song earlier (closing Rhythmbox or muting its stream in PulseAudio Volume Control fixes this).

This problem seems to be related to alsa-plugins-pulseaudio. Running arecord from the command line fails too (but works if alsa-plugins-pulseaudio is removed from the system).

This might be related: https://bugzilla.redhat.com/show_bug.cgi?id=472469
Comment 7 Tom London 2009-03-04 10:52:32 EST
This now "works for me" with rawhide package.
Comment 8 Gideon Mayhak 2009-04-22 22:35:50 EDT
Seems to be working fine for me.  Sorry I didn't chime in sooner.

Note You need to log in before you can comment on or make changes to this bug.