Bug 470653 - Packages from external repos not seen in package selection; mandatory packages don't get installed
Packages from external repos not seen in package selection; mandatory packag...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-08 07:25 EST by Thorsten Leemhuis
Modified: 2008-11-15 03:45 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-15 03:45:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from install with RPM Fusion Free enabled (23.29 KB, text/plain)
2008-11-09 03:48 EST, Thorsten Leemhuis
no flags Details
anaconda log with a different repo that has a different comps.xml (23.14 KB, text/plain)
2008-11-09 06:53 EST, Thorsten Leemhuis
no flags Details

  None (edit)
Description Thorsten Leemhuis 2008-11-08 07:25:36 EST
Description of problem:
Enabling the RPM Fusion free repo during a standard Fedora rawhide install does not give the desired result:

- Packages from the RPM Fusion free repo are not selectable in the Package Selection within anaconda 

- the rpmfusion-free-release package, which the comps.xml from RPM Fusion adds to the core group and marks as "mandatory" is not getting installed

Version-Release number of selected component (if applicable):
boot.iso from 20081107

Steps to Reproduce:
1. fire off a install using boot.iso
2. enable RPM Fusion free for rawhide as add-on repository when getting to the software selection screen in anaconda; repository name: foobar; repository URL [for ix86]: http://download1.rpmfusion.org/free/fedora/development/i386/os/
3. Select "Curtomize now"
-> no packages from RPM Fusion can be found in the package selection
4. Continue install
-> rpmfusion-free-release not installed

Additional info:
Note, maybe the comps.xml files from RPM Fusion are wrong and thus completely or partly the root case for the problem; but I designed them after advice from Jesse in
https://www.redhat.com/archives/fedora-devel-list/2008-September/msg02097.html

Comps.xml can be found here:
http://cvs.rpmfusion.org/viewvc/comps/comps-f10.xml.in?root=free&view=markup

I build pirut from Fedora cvs for F8 on a up2date rawhide machine to check if it works well with the current compx.xml file from RPM Fusion. Is does; see
http://lists.rpmfusion.org/pipermail/rpmfusion-developers/2008-November/002210.html
and the screenshots attached to it.

Also note that Jeremy tried to solve this problem (which creates trouble for some years now without getting properly fixed; this is the third bug about it iirc):
https://www.redhat.com/archives/fedora-devel-list/2008-September/msg02100.html
Comment 1 Jeremy Katz 2008-11-08 16:19:10 EST
Can you grab the anaconda.log from the install?  (/var/log/anaconda.log if you let it finish)

And then I'll take a look at it and see where I can get from there as I really think this *should* be working now.
Comment 2 Thorsten Leemhuis 2008-11-09 03:48:56 EST
Created attachment 322993 [details]
log from install with RPM Fusion Free enabled

(In reply to comment #1)
> Can you grab the anaconda.log from the install?  (/var/log/anaconda.log if you
> let it finish)

Attached

> And then I'll take a look at it and see where I can get from there

tia!

> as I really think this *should* be working now.

As mentioned earlier, maybe it's the comps.xml format from RPM Fusion that's wrong.
Comment 3 Thorsten Leemhuis 2008-11-09 06:53:19 EST
Created attachment 322997 [details]
anaconda log with a different repo that has a different comps.xml

(In reply to comment #2)
> > as I really think this *should* be working now.
> As mentioned earlier, maybe it's the comps.xml format from RPM Fusion that's
> wrong.

I did one more test to check how the format of comps.xml influences the behavior: I used the latest boot.iso from rawhide and enabled the rpmfusion updates repo for Fedora 9 (http://download1.rpmfusion.org/free/fedora/updates/9/i386/) during install. Normally that is something one should never do, but its a nice way to test as a different comps.xml is used for the F9 repo. 

For reference, here's the URI to RPM Fusion's comps.xml files from F9 and F10:
http://cvs.rpmfusion.org/viewvc/comps/comps-f9.xml.in?root=free&view=markup
http://cvs.rpmfusion.org/viewvc/comps/comps-f10.xml.in?root=free&view=markup

As you can see, the F10 comps.xml from RPM Fusion tries to extend the groups from Fedora. The one for F9 otoh defines RPM Fusion specific groups; their IDs and Names are different from the ones used by Fedora.

But the package selection doesn't work with the F9 comps as well. The problems are quite similar to the one in the initial bug report:

- Packages from the RPM Fusion free repo are not selectable in the "pirut-like" Package Selection screen from anaconda; none of the RPM Fusion specific groups is shown
 
- the rpmfusion-free-release package, which the comps.xml from RPM Fusion marks as "mandatory" in a default select group is not getting installed
Comment 4 Jeremy Katz 2008-11-12 17:13:37 EST
I think I figured out what's going on and sent a patch for it to anaconda-devel-list.  Will give a full test this evening and hopefully can get it into tomorrow's rawhide
Comment 5 Jeremy Katz 2008-11-12 17:58:25 EST
Tested and cleaned up the stupid thinkos in the patch and resent it.
Comment 6 Thorsten Leemhuis 2008-11-13 09:49:13 EST
Many many thx for working on this jeremy. I saw it got added to the anaconda that was build for devel; is there still a chance/some way to get this integrated into anaconda for F-10?
Comment 7 Jeremy Katz 2008-11-13 10:20:19 EST
Gah, that was the intent.  It looks like Chris just did the build in the wrong place.  Will get fixed up for tomorrow
Comment 8 Thorsten Leemhuis 2008-11-15 03:45:11 EST
I gave it a test and it seems to work now; thx jeremy!

Note You need to log in before you can comment on or make changes to this bug.