Bug 47070 - Random kernel panics (maybe related to network)
Random kernel panics (maybe related to network)
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-02 19:58 EDT by Joerg Ludwig
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-08 20:40:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joerg Ludwig 2001-07-02 19:58:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows NT 5.0)

Description of problem:
My Linux-Server (P120, 64MB RAM, 4GB HDD, 2x PCI-NIC) ran for about a year 
with SuSE Linux 6.4 / 7.0 without any crashes. Last week I reinstalled it 
using RedHat 7.1 and since then I got about one kernel panic a day!

How reproducible:
Always

Steps to Reproduce:
1. I cannot reproduce the failure.
2. I occurs from time to time when I access the server by network.

Actual Results:  I get a kernel panic message on the screen and have to 
reset the computer.

Expected Results:  The server should run without kernel panics?!

Additional info:

The messages I saw on the screen:

========
pmd entry c258e00c: 0000000000000000
... pmd not present!
Oops: 0000
CPU:    0
EIP:    0010:[<c01e1f08>]
EFLAGS: 00010206
eax: 00f00000   ebx: c3da8360   ecx: c11e3958   edx: 00000000
esi: c37e70c0   edi: c37e71f4   ebp: c3da8360   esp: c3a0dcbc
ds: 0018   es: 0018   ss: 0018
Process sockd (pid: 8901, stackpage=c3a0d000)
Stack: 00000000 c37b8de0 c06a7c00 c37b8de0 00000000 c37e70c0 c37e71f4 
c01e241d
       c37e70c0 c3da8360 00000000 00000000 01000438 c07c2b00 c37b8de0 
c06a7c00
       00000002 c07c0438 c37b8de0 c06a7c00 c01cbe28 00000000 c1ff5c34 
00000418
Call Trace: [<c01e241d>] [<c01cbe28>] [<c01c205c>] [<c01cbc1c>] 
[<c01cbb10>] [<c
01c2302>] [<c01cbb10>]
       [<c01c2339>] [<c01cb755>] [<c01cbb10>] [<c01cbe28>] [<c01cbc90>] 
[<c01c23
02>] [<c01cbc90>] [<c01c2339>]
       [<c01cbac6>] [<c01cbc90>] [<c01bcfcc>] [<c010a35a>] [<c0119d82>] 
[<c010a5
0f>] [<c0109070>] [<c013c8e9>]
       [<c01b65ff>] [<c0141b8c>] [<c0142029>] [<c0108fb3>]

Code: 8b 78 04 83 c0 08 57 50 53 e8 0a 9d fd ff 83 c4 0c 85 c0 ba
Kernel panic: Aiee, killing interrupt handler!
In interrupt handler - not syncing

========
Oops: 0000
CPU:    0
EIP:    0010:[<c01e1f08>]
EFLAGS: 00010206
eax: 0000ff00   ebx: c03ca140   ecx: c38ee060   edx: 00000000
esi: c38ee060   edi: c38ee194   ebp: c03ca140   esp: c2797c3c
ds: 0018   es: 0018   ss: 0018
Process telnet (pid: 1805, stackpage=c2797000)
Stack: c0265240 c2797cb4 00000000 c0265240 00000000 c38ee060 c38ee194 
c01e241d
       c38ee060 c03ca140 c02e8040 00000800 00000019 00000000 c0265240 
c01c2339
       00000001 00000019 c02e8040 c26dc294 00000003 00000000 c1c97ab8 
c03ca140
Call Trace: [<c01e241d>] [<c01c2339>] [<c01c205c>] [<c01cbc1c>] 
[<c01cbb10>] [<c
01c2302>] [<c01cbb10>]
       [<c01c2339>] [<c01cb755>] [<c01cbb10>] [<c01cbc90>] [<c01c205c>] 
[<c01cbe
28>] [<c01cbc90>] [<c01c2302>]
       [<c01cbc90>] [<c01c2339>] [<c01e1f78>] [<c01cbac6>] [<c01cbc90>] 
[<c01dc3
6a>] [<c01bcfcc>] [<c0119d82>]
       [<c0113c41>] [<c0113b17>] [<c01eb537>] [<c01eb6f2>] [<c01b6d36>] 
[<c01cbc
90>] [<ff005d36>] [<c01b6977>]
       [<c016de9f>] [<c01b909b>] [<c01b922a>] [<c01b7664>] [<c0108fb3>]

Code: 8b 78 04 83 c0 08 57 50 53 e8 0a 9d fd ff 83 c4 0c 85 c0 ba
Kernel panic: Aiee, killing interrupt handler!
In interrupt handler - not syncing

========
I think that it is interresting that the output of both kernel panics is 
nearly identic, although they seem to be caused by different processes.

Please help, I do NOT want to reinstall the server again using SuSE ;)
Comment 1 Arjan van de Ven 2001-07-03 03:57:45 EDT
First of all, we released an updated kernel 2 weeks ago (2.4.3-12) and
it's worth trying that. You can download the rpm from updates.redhat.com
or by using the up2date tool to do everything for you.

Second question: could you describe your hardware a bit (cpu types, memorysize,
if known: motherboard type)
Comment 2 Joerg Ludwig 2001-07-03 13:19:41 EDT
I just updated the kernel via up2date.
Now I am waiting for the next kernel panic :)
Comment 3 Joerg Ludwig 2001-07-08 20:40:05 EDT
No more kernel panics occured,
the problem seems to be solved :)
Thx.
Comment 4 Arjan van de Ven 2001-07-09 04:43:14 EDT
Ok, I'll close this as "fixed in errata", if it comes back, please reopen
the bug.

Note You need to log in before you can comment on or make changes to this bug.