Bug 470707 - no sound in flash plugin
no sound in flash plugin
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-08 22:42 EST by Mark
Modified: 2008-11-16 11:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-16 11:50:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark 2008-11-08 22:42:41 EST
Description of problem: I have flash 10 plugin installed on Fedora 10 preview and I have no sound.


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1.youtube
2.play video
3.no sound
  
Actual results: not a peep


Expected results: sound


Additional info: All other sound works.  System sounds, mo3 playback, video playback, etc.
Comment 1 Mark 2008-11-09 19:20:29 EST
I got this fixed, although i'm not sure it's fixed correctly.  I installed both the .386 and .amd64 versions of ndispluginwrapper and libflashsupport and now youtube video and audio works.
Comment 2 Mads Kiilerich 2008-11-11 18:59:21 EST
Please report exact version numbers for
kernel
pulseaudio
nspluginwrapper
libflashsupport
flash-plugin

Rumours says and experience confirms that libflashsupport makes no difference for flash 10 - can you verify that?

Is is my experience (Bug 459011) that it is very hard to point out exactly what makes flash problems appear or go away. Could you try uninstalling and reinstalling the nspluginwrappers and verify exactly what makes your problem come or go?

If you think it is related to pulseaudio then run
pulseaudio -k
pulseaudio -vvv
and post the output
Comment 3 Mark 2008-11-11 20:08:41 EST
(In reply to comment #2)
> Please report exact version numbers for
> kernel
> pulseaudio
> nspluginwrapper
> libflashsupport
> flash-plugin
> 
> Rumours says and experience confirms that libflashsupport makes no difference
> for flash 10 - can you verify that?
> 
> Is is my experience (Bug 459011) that it is very hard to point out exactly what
> makes flash problems appear or go away. Could you try uninstalling and
> reinstalling the nspluginwrappers and verify exactly what makes your problem
> come or go?
> 
> If you think it is related to pulseaudio then run
> pulseaudio -k
> pulseaudio -vvv
> and post the output

 kernel 2.6.27.5-94.fc10.x86_64
 pulseaudio 0.9.13
 nspluginwrapper 1.1.2 (both 32bit and 64bit)
 libflashsupport 000-0.5.svn20070904
 flash-plugin 10.0.12.36

I've read/heard the rumors too.

All I know is I had no video until i installed the 32bit nspluginwrapper (not installed by default)

Then I had no sound until I installed the libflashsupport (both 32 and 64bit)
Comment 4 Mads Kiilerich 2008-11-11 20:27:40 EST
Well ... then that is just how it is.

Fedora contains the components to make the proprietary plugin work, even on an unsupported platform. Fedora can't and won't do much more to support it. So your experience really belongs in an unofficial fedora faq. Oh ... it is there already ;-)

I think this issue could be closed.
Comment 5 Mark 2008-11-11 22:39:01 EST
That's fine, it can be closed.  The reason i filed the bug was because there is clear documentation that says libflashsupport is not needed.  That is clearly not true.
Comment 6 Mads Kiilerich 2008-11-14 19:15:12 EST
What clear documentation saying that have you seen? Can you give exact pointers - and/or help getting it fixed there?

As filer you can close this issue - I can't.
Comment 7 Mads Kiilerich 2008-11-16 07:29:11 EST
Mark, the description on http://docs.fedoraproject.org/release-notes/f10preview/en_US/What_is_the_Latest_on_the_Desktop.html#sn-Web_browsers could perhaps be improved, but it do say exactly what you experienced; that libflashsupport.i386 is needed on x64.
Comment 8 Mark 2008-11-16 11:50:35 EST
Yes.

There are many errant forum posts out there, but hopefully this bug report will help if someone has the same problem.

I am closing this bug.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.