Bug 470753 - The EDAC driver not support The Intel 3200 and 3210 Chipsets
The EDAC driver not support The Intel 3200 and 3210 Chipsets
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.9
All Linux
medium Severity medium
: rc
: ---
Assigned To: Mauro Carvalho Chehab
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-09 19:37 EST by Haruo Tomita
Modified: 2013-07-04 18:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-27 14:04:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (13.06 KB, patch)
2008-11-09 19:38 EST, Haruo Tomita
no flags Details | Diff
dmesg (29.33 KB, text/plain)
2008-11-09 19:42 EST, Haruo Tomita
no flags Details

  None (edit)
Description Haruo Tomita 2008-11-09 19:37:26 EST
Description of problem:
The EDAC driver of the Intel 3200 and 3210 Chipsets is not supported in the latest stable version of RHEL4(RHEL4.7).


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
The EDAC driver of the Intel 3200 and 3210 Chipsets is load.

Expected results:


Additional info:
Comment 1 Haruo Tomita 2008-11-09 19:38:59 EST
Created attachment 323031 [details]
patch

The EDAC driver of the Intel 3200 series is open to the public as follows. 

http://sourceforge.net/mailarchive/forum.php?thread_name=20080724045805.GA22926%40juhlenko-desk.sanmateo.corp.akamai.com&forum_name=bluesmoke-devel

I backpoted this patch to EL4.7. 
(See attached file: linux-2.6.9-edac-i3200-support.patch)
Comment 2 Haruo Tomita 2008-11-09 19:42:41 EST
Created attachment 323032 [details]
dmesg

The EDAC driver was tested by using DIMM that generated the correctable error.
The result is as follows. 

MC0: CE page 0x0, offset 0x0, grain 536870912, syndrome 0x1c0000, row 0, channel 0, label "": i3200 CE
MC0: CE page 0x0, offset 0x0, grain 536870912, syndrome 0x1c0000, row 0, channel 0, label "": i3200 CE
MC0: CE page 0x0, offset 0x0, grain 536870912, syndrome 0x1c0000, row 0, channel 0, label "": i3200 CE
MC0: CE page 0x0, offset 0x0, grain 536870912, syndrome 0x1c0000, row 0, channel 0, label "": i3200 CE
MC0: CE page 0x0, offset 0x0, grain 536870912, syndrome 0x1c0000, row 0, channel 0, label "": i3200 CE

The EDAC driver fine works.
(See attached file: dmesg-EL4.7-i3200-edac)
Comment 3 Mauro Carvalho Chehab 2008-11-20 15:28:14 EST
The driver weren't added yet at Linus tree nor at linux-next. This driver still needs some soak time.
Comment 5 RHEL Product and Program Management 2009-03-12 14:54:15 EDT
Since RHEL 4.8 External Beta has begun, and this bugzilla remains 
unresolved, it has been rejected as it is not proposed as exception or 
blocker.
Comment 6 RHEL Product and Program Management 2010-10-27 14:04:41 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request.
Comment 7 Mike Khusid 2010-10-27 14:08:34 EDT
Red Hat does not currently plan to provide this enhanced functionality in a Red Hat Enterprise Linux update for currently deployed products.

With the goal of minimizing risk of change for deployed systems, and in response to customer and partner requirements, Red Hat takes a conservative approach when evaluating enhancements for inclusion in maintenance updates for currently deployed products. The primary objectives of update releases are to enable new hardware platform support and to resolve critical defects.

For more information on Red Hat Enterprise Linux maintenance policies, please consult: http://www.redhat.com/security/updates/errata/

Red Hat values your feedback and will take this enhancement request into consideration for future major releases of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.