Bug 47076 - Installer crashes pressing 'Esc' on partition edit dialog
Installer crashes pressing 'Esc' on partition edit dialog
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 46766 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-02 21:51 EDT by Nitin Dahyabhai
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-05 12:54:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nitin Dahyabhai 2001-07-02 21:51:55 EDT
Description of problem:
Pressing the escape key when the partition setup dialog causes an
exceptional condition.

How reproducible:
Always

Steps to Reproduce:
1) Load GUI install and set for custom editing the partitions
   using Disk Druid.
2) Select ANY partition and click the 'Edit' button.
3) Press 'Esc'.

Actual Results:  Exceptional condition raised; won't save to floppy due to
mkdosfs problem.  Approximate stack trace:

File "/usr/bin/anaconda", line 561 in ?
	intf.run(id,dispatch)
...
File "/usr/lib/anaconda/iw/partition_gui.py", line 1043 in editCb
	self.editPartitionRequest(request)
File "/usr/lib/anaconda/iw/partition_gui.py", line 795 in
editPartitionRequest
	raise ValueError,"Error while running edit partition request dialog."

Additional info:
Comment 1 Michael Fulbright 2001-07-05 12:54:47 EDT
*** Bug 46766 has been marked as a duplicate of this bug. ***
Comment 2 Michael Fulbright 2001-07-05 16:04:38 EDT
Fixed.

Note You need to log in before you can comment on or make changes to this bug.