Bug 470784 - amarok: cannot play song
amarok: cannot play song
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-10 03:55 EST by Flóki Pálsson
Modified: 2009-01-02 18:47 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-21 18:04:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
start form terminal amarok 2> amarok2.txt (92.82 KB, text/plain)
2008-11-10 16:51 EST, Flóki Pálsson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 174748 None None None Never

  None (edit)
Description Flóki Pálsson 2008-11-10 03:55:56 EST
Description of problem:
I can not play song with amarok. It is possible to use xine.

Version-Release number of selected component (if applicable):
amarok-1.94-2.fc10.x86_64
xine-0.99.5-5.fc10.x86_64
phonon-backend-xine-4.1.2-5.fc10.x86_64

How reproducible:
always

Steps to Reproduce:
1.
s
2.
3.
  
Actual results:


Expected results:


Additional info:
Se 
http://bugs.kde.org/show_bug.cgi?id=174748
Comment 1 Rex Dieter 2008-11-10 08:58:59 EST
Works fine here playing my song collection, I cannot reproduce.

Also tried the problematic file referenced in upstream report:
http://he3.magnatune.com/all/02--Sonata%20Prima%20Detta%20La%20Poggia%20(Marco%20Uccellini)--Altri%20Stromenti.ogg

Happy here too.

I suspect that you're having an issue with phonon, not specific to amarok.

For example, do other kde audio-type things work?  For example, does anything in 
systemsettings->notifications (sound events) work?
Comment 2 Flóki Pálsson 2008-11-10 16:51:24 EST
Created attachment 323122 [details]
start form terminal  amarok 2> amarok2.txt

I am running gnome.  
xine can play sound. 
rhythmbox-0.11.6-15.6005.fc10.x86_64 too. 

"For example, do other kde audio-type things work?"
Only kde software which is installed is quanta and amarok.
audio-type things ??

There is no selection between gnome and kde in login. 
In first start off amarok then there was no configuration as in amarok 1.4 in fc9.
There was no selection beetween mysql and slqlite.

FC10 installed from F10-PR-x86_64-Live.iso.
Comment 3 Bug Zapper 2008-11-26 00:06:37 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 martin coker 2008-11-27 10:08:49 EST
Just joining here as I have just installed F10 final and I have no audio with amarok on any of my mp3 collection. Exaile, xine rythmbox etc have no problem. The only other issue I have is that real player will not run but that is not part of the redhat fedora project so I will have to post to helix community.
Comment 5 Rex Dieter 2008-11-27 21:23:45 EST
Amarok's (default) use of phonon-backend-xine doesn't support mp3 playback out fo the box. (you need xine-lib-extras-freeworld from rpmfusion, or the like).
Comment 6 Flóki Pálsson 2008-11-28 07:26:30 EST
Amarok can not play ogg files.
Comment 7 Christian Nolte 2008-11-30 15:21:38 EST
Just a 'me too': To reproduce, do the following:

- Login using a GNOME session
- Start amarok
- Start playback of either .ogg or .mp3

I hear no sound.

[nolte@ravine ~]$ rpm -qa | grep -i xine
xine-lib-extras-freeworld-1.1.15-4.fc10.i386
xine-0.99.5-5.fc10.i386
libXinerama-1.0.3-2.fc10.i386
xine-lib-1.1.15-3.fc10.i386
libXinerama-devel-1.0.3-2.fc10.i386
totem-xine-2.24.3-1.fc10.i386
xine-lib-extras-1.1.15-3.fc10.i386
phonon-backend-xine-4.1.3-1.fc10.i386
xine-lib-pulseaudio-1.1.15-3.fc10.i386
Comment 8 Rex Dieter 2008-11-30 18:53:55 EST
Hrm, I can hear things logging into gnome or even xfce.  

On possibility is perhaps there's a magic extra package I have installed.
Comment 9 Christian Nolte 2008-12-01 14:29:02 EST
Hmmm... Somehow I now have sound using amarok from within gnome. The last steps I did are:

Nov 30 21:17:40 Erased: alsa-plugins-pulseaudio
Nov 30 21:33:52 Installed: pulseaudio-debuginfo-0.9.13-6.fc10.i386
Nov 30 21:37:44 Erased: xine-lib-pulseaudio
Nov 30 22:04:58 Installed: xine-lib-pulseaudio-1.1.15-3.fc10.i386
Comment 10 Daniel Laczi 2008-12-03 08:11:04 EST
I just installed Fedora 10 final and I have the same problem. I use GNOME, so I haven't installed full KDE.

Packets that are installed on my machine:
amarok-1.98-1.fc10.i386
xine-0.99.5-5.fc10.i386
phonon-4.2.0-7.fc10.i386

Can somebody change the Platform to "All"? As you see the bug also exists on my i386 installation.

I also wonder, because there is no "status bar" which shows the song that is currently being played, the remainig time, etc.
Comment 11 Rex Dieter 2008-12-03 09:10:03 EST
alias, is phonon-backend-xine installed?
Comment 12 Daniel Laczi 2008-12-04 02:40:18 EST
Yes, it is. The following packets are installed:

[mrx@laptop ~]# rpm -qa | grep -i xine
libXinerama-1.0.3-2.fc10.i386
xine-0.99.5-5.fc10.i386
xine-lib-pulseaudio-1.1.15-3.fc10.i386
phonon-backend-xine-4.1.3-1.fc10.i386
totem-xine-2.24.3-1.fc10.i386
xine-plugin-1.0.1-4.fc10.i386
xine-lib-extras-freeworld-1.1.15-4.fc10.i386
xine-lib-1.1.15-3.fc10.i386
libXinerama-devel-1.0.3-2.fc10.i386

[mrx@laptop ~]# rpm -qa | grep -i phonon
phonon-4.2.0-7.fc10.i386
phonon-backend-xine-4.1.3-1.fc10.i386
Comment 13 Flóki Pálsson 2008-12-07 19:20:47 EST
Now I cam play song with amarok.
I am using FC10 gnome ( Fedora-10-x86_64-DVD.iso ).
I have installed Quanta ( kdewebdev ).
I can play ogg and from web and even mp3.

I can have not been able to play from external disk,  which is vissable in amarok. 
   

Instaled. ( hint on http://forums.fedoraforum.org/showthread.php?t=205019&highlight=amarok) 

[floki@flokip ~]$ rpm -qa |egrep 'phonon|gstream|amarok'
gstreamer-python-0.10.12-1.fc10.x86_64
PackageKit-gstreamer-plugin-0.3.11-1.fc10.x86_64
gstreamer-plugins-base-0.10.21-2.fc10.x86_64
totem-gstreamer-2.24.3-1.fc10.x86_64
phonon-4.2.0-7.fc10.x86_64
gstreamer-0.10.21-2.fc10.x86_64
gstreamer-plugins-flumpegdemux-0.10.15-4.fc10.x86_64
phonon-backend-xine-4.1.3-1.fc10.x86_64
gstreamer-tools-0.10.21-2.fc10.x86_64
amarok-1.98-1.fc10.x86_64
gstreamer-plugins-good-0.10.11-1.fc10.x86_64
gstreamer-plugins-ugly-0.10.9-2.fc10.x86_64
phonon-backend-gstreamer-4.2.0-7.fc10.x86_64
[floki@flokip ~]$
Comment 14 Rex Dieter 2008-12-21 18:04:54 EST
Closing per comment #13 (most likely issue was a lack of a usable phonon backend), others with similar issues, please file separately.
Comment 15 Flóki Pálsson 2008-12-21 20:02:23 EST
I reinstalled F10.

After installing amarok then I could not play.
But after installing    
phonon-backend-gstreamer
I can play song. ( mp3 )
I can not now play ogg or oga.
I can play ogg and oga with GXine.
( xine has Segmentation fault )

Should phonon-backend-gstreamer not be innstalled with amarok. 



Installed  with amarok
Dec 21 23:34:25 Installed: clucene-core.x86_64 0.9.21-1.fc10
Dec 21 23:34:26 Installed: strigi-libs.x86_64 0.5.11-1.fc10
Dec 21 23:34:27 Installed: soprano.x86_64 2.1.1-1.fc10
Dec 21 23:34:28 Installed: mysql-embedded.x86_64 5.0.67-2.fc10
Dec 21 23:34:29 Installed: loudmouth.x86_64 1.4.3-1.fc10
Dec 21 23:34:30 Installed: kde-filesystem.noarch 4-20.fc10
Dec 21 23:34:31 Installed: kdelibs-common.x86_64 6:4.1.3-4.fc10
Dec 21 23:35:08 Installed: oxygen-icon-theme.noarch 4.1.3-1.fc10
Dec 21 23:35:09 Installed: solar-backgrounds-common.noarch 0.92.0-1.fc10
Dec 21 23:35:10 Installed: solar-kde-theme.noarch 0.1.16-2.fc10
Dec 21 23:35:11 Installed: kde-settings.noarch 4.1-4.20081031svn.fc10
Dec 21 23:35:12 Installed: phonon.x86_64 4.2.0-7.fc10
Dec 21 23:35:34 Installed: kdelibs.x86_64 6:4.1.3-4.fc10
Dec 21 23:35:42 Installed: amarok.x86_64 2.0-2.fc10
Dec 21 23:35:43 Installed: phonon-backend-xine.x86_64 4.1.3-1.fc10

but not
Dec 22 00:01:27 Installed: phonon-backend-gstreamer.x86_64 4.2.0-7.fc10
Comment 16 Rex Dieter 2008-12-21 20:34:02 EST
phonon-backend-xine + xine-lib-pulseaudio is the default, recommended choice.

Note You need to log in before you can comment on or make changes to this bug.