Bug 470789 - GDM starts instant reboot
GDM starts instant reboot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
high Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-10 05:16 EST by Jóhann B. Guðmundsson
Modified: 2008-12-01 05:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 05:23:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2008-11-10 05:16:08 EST
Description of problem:

Just updated to latest build -44 and as soon as GDM starts 
the machine reboots.. 

Been systematically down grading the driver.. 

-44 = GDM starts instant reboot
-43 = GDM starts instant reboot
-42 = GDM starts instant reboot
-41 = Works!

Most likely the cause of this is...
- radeon-modeset.patch: fix rotation + dpms

Introduced in build -42

ATI Technologies Inc M22 [Radeon Mobility M300] Card.

It would be good if you could build -45 without this patch
so I can confirm or you can give me instruction on how to
remove the patch from the source rpm. 

Version-Release number of selected component (if applicable):

How reproducible:

Always

Steps to Reproduce:
1. Start the machine in run level 5
2.
3.
  
Actual results:

Instant reboot when GDM starts

Expected results:

Stability..

Additional info:

nomodeset bypasses this issue.
Comment 1 Dave Airlie 2008-11-10 05:55:02 EST
what kernel are you running?

care you try latest -92 kernel from koji and see if -ati still causes it.

A reboot seems like a really unusual issue, I can supply some test packages to try and narrow down which of the patch in 42 might have caused it.
Comment 2 Jóhann B. Guðmundsson 2008-11-10 06:10:38 EST
I Tested it with kernel 5-92 and it was not until I downgraded the ati driver to -41 it stopped...

I tested it also against kernels 4-79 and 4-68 as well before starting to down grade the ati driver.
Comment 3 Jóhann B. Guðmundsson 2008-11-10 09:12:12 EST
"I can supply some test packages to try and narrow down which of the patch in 42 might have caused it"

Will these test packages appear in koji or via url you will provide?
Comment 4 Jóhann B. Guðmundsson 2008-11-12 10:12:23 EST
Just tested with kernel -101 and drv-ati -44 and the system froze 

Reverting the ati driver back to -41 resulted not in a system freeze..
Comment 5 Jóhann B. Guðmundsson 2008-11-13 06:00:31 EST
Just tested with kernel -104 and drv-ati -44 and the system froze as soon as 
gdm starts. 

Reverting the ati driver back to -41 resulted not in a system freeze..

Any news from those test packages so we can narrow what causes this that 
got introduced in -42

Note the behaviour has change from instant reboot to system freeze with 
the latest kernels.
Comment 6 Dave Airlie 2008-11-13 07:31:56 EST
Yeah I found the change that caused it however I haven't found the correct fix.

I removed a workaround from -41 that broke things, I don't want to put it back in as it shouldn't be needed. I hopefully have the real fix in hand tomorrow.
Comment 7 Jóhann B. Guðmundsson 2008-11-14 05:33:18 EST
With kernel -109 and drv-ati -46 we are back to instant reboot as 
soon as gdm starts...
Comment 8 Jóhann B. Guðmundsson 2008-11-18 05:37:09 EST
With kernel -116 and ati -51 the system does not reboot itself 
however experiencing graphical glitches ( background in GDM scrambled but eventually loads and if I log in and have a terminal window open and firefox 
and then switch between them the system freezes )

System also feels significantly more responsive.

Should this be closed as FIXED since it has stop instantly rebooting itself
as soon as it enters GDM and moved to the parent bug of the ATI cards?

Seeing in Xorg log lots of  

RADEON DRM CS failure - corruptions/glitches may occur -12
bufmgr: last submission...
Comment 9 Bug Zapper 2008-11-26 00:06:45 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Matěj Cepl 2008-12-01 05:23:14 EST
Closing as RAWHIDE, please, open a new bug for whatever else doesn't work properly.

Note You need to log in before you can comment on or make changes to this bug.