Bug 470800 - BAT (Bacula Administration Tool) is missing in the RPM
BAT (Bacula Administration Tool) is missing in the RPM
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: bacula (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-10 06:48 EST by JM
Modified: 2008-12-02 20:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 20:15:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JM 2008-11-10 06:48:26 EST
bat the "Bacula Administration Tool" (http://www.bacula.org/en/rel-manual/GUI_Programs.html and http://www.bacula.org/en/rel-manual/Installing_Bacula.html#enablebat) is missing in the RPM (I tried bacula-2.4.3-1.fc10 RPM), would it possible to include it in the next release of the RPM?
Comment 1 Jon Ciesla 2008-11-10 09:46:16 EST
I'll see if this is feasible.
Comment 2 Jon Ciesla 2008-11-17 13:40:12 EST
Built in rawhide.  Please test.  Works for me.
Comment 3 JM 2008-11-17 14:59:43 EST
I checked http://download.fedora.redhat.com/pub/fedora/linux/development/source/SRPMS/ but there is only the "old" version "bacula-2.4.3-1.fc10", do you have a direct URL to the SRPM?
Comment 4 Jon Ciesla 2008-11-17 15:08:12 EST
There hadn't been a compose.

koji link:

http://koji.fedoraproject.org/koji/buildinfo?buildID=70031
Comment 5 JM 2008-11-17 15:25:57 EST
Thank you, the URL works, I have to rebuild the SRPM which takes some time :-). 

Btw. is the "2.4.3-orphaned-jobs.patch" (http://www.bacula.org/en/?page=news) already part of the new SRPM?
Comment 6 Jon Ciesla 2008-11-17 15:34:47 EST
Oooh, no it isn't.  Adding, will test build and rebuild for rawhide soon. . .
Comment 7 JM 2008-11-17 18:25:22 EST
The SRPM with "bat" works for me.

Btw. "logrotate" rotates "/var/log/bacula/*.log and /var/spool/bacula/log" but in the /etc/bacula-dir.conf file there is also an entry which creates a "/var/log/bacula.log" file, I changed it to "/var/log/bacula/bacula.log"... but I don't know if this is correct.
Comment 8 Jon Ciesla 2008-11-18 08:23:43 EST
I'm committing a version with logrotate changed to include /var/log/bacula.log.  This way it will catch what people already have.
Comment 9 Jon Ciesla 2008-11-18 13:35:53 EST
Koji build fixing all of the above, please test:

http://koji.fedoraproject.org/koji/buildinfo?buildID=70106
Comment 10 JM 2008-11-18 15:29:26 EST
Works for me. Thank you!
Comment 11 Fedora Update System 2008-11-19 09:17:00 EST
bacula-2.4.3-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/bacula-2.4.3-3.fc10
Comment 12 Fedora Update System 2008-11-22 11:51:41 EST
bacula-2.4.3-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bacula'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/f10/FEDORA-2008-10000
Comment 13 Bug Zapper 2008-11-26 00:07:20 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Fedora Update System 2008-12-02 20:15:42 EST
bacula-2.4.3-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.