Bug 470805 - Allow passing hexadecimal ids to "ipmitool sel delete"
Allow passing hexadecimal ids to "ipmitool sel delete"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: OpenIPMI (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jan Safranek
BaseOS QE
:
Depends On: 456246
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-10 07:26 EST by Jan Safranek
Modified: 2009-09-02 05:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:59:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Safranek 2008-11-10 07:26:36 EST
+++ This bug was initially created as a clone of Bug #456246 +++

Description of problem:

"ipmitool sel list" list entries with the id in hexadecimal, but the "ipmitool
sel delete" does not parse hexadecimal values, which cause some confusion.

Version-Release number of selected component (if applicable):

ipmitool-1.8.9

How reproducible:

100% reproducible

Steps to Reproduce:
1.List SEL entries with
  # ipmitool sel list
2. Try to delete one of the entries
  # ipmitool sel delete 0x0100
  
Actual results:

Unable to delete entry 0: Invalid command

Expected results:

Unable to delete entry 256: Invalid command

Additional info:

The "Delete SEL command" is not available on all IPMI implementations (thus the
need for the "Get SEL Info Command" as defined in the IPMI 2.0 specification
that indicates if the delete command is available), but nevertheless "ipmitool
sel delete" command should be able to parse hexadecimal values to match the
output of "ipmitool sel list".

The (very simple) patch attached adds this functionality.

--- Additional comment from jsafrane@redhat.com on 2008-10-24 03:51:34 EDT ---

I can see it was sent upstream, with with no response...

 https://sourceforge.net/mailarchive/message.php?msg_name=60f2b0dc0808161356m70895ac3l6f60a312441dc802%40mail.gmail.com
Comment 1 Jan Safranek 2009-01-15 04:30:39 EST
The patch was finally accepted upstream.
Comment 3 Jan Safranek 2009-03-16 11:47:44 EDT
Fixed by rebase to ipmitool-1.8.11
Comment 7 errata-xmlrpc 2009-09-02 05:59:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1312.html

Note You need to log in before you can comment on or make changes to this bug.