Bug 470807 - NetworkManager tries to start wlan0 even though eth0 is connected
NetworkManager tries to start wlan0 even though eth0 is connected
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: NetworkManager (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Dan Williams
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-10 07:38 EST by Ben Levenson
Modified: 2008-11-10 16:44 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-10 16:44:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2008-11-10 07:38:54 EST
Description of problem:
NetworkManager tries to start wlan0 even though eth0 is connected

Version-Release number of selected component (if applicable):
NetworkManager-gnome-0.7.0-0.11.svn4185.el5.x86_64
NetworkManager-0.7.0-0.11.svn4185.el5.x86_64
NetworkManager-0.7.0-0.11.svn4185.el5.i386
NetworkManager-glib-0.7.0-0.11.svn4185.el5.x86_64
NetworkManager-glib-0.7.0-0.11.svn4185.el5.i386

How reproducible:
100%

Steps to Reproduce:
1. upgrade laptop from 5.2 to 5.3
2. Start gnome
  
Actual results:
NetworkManager will make at least 3 attempts to start my wireless connection
even though I already have an IP on eth0

Additional info:
An additional wired connection is listed in the dropdown menu: "eth0" + "System 
eth0"
Comment 1 Dan Williams 2008-11-10 16:44:33 EST
This is expected with 0.7 because it now supports multiple active devices, and connection sharing, etc...

If there are specific regressions in behavior due to this we should file them separately, but in general, the active device (the one that has the default route) will be the same device that NM 0.6 would have chosen.

Note You need to log in before you can comment on or make changes to this bug.