Bug 470817 - pirut (pup) crashes on launch due to malformed updateinfo.xml from RHN
pirut (pup) crashes on launch due to malformed updateinfo.xml from RHN
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Other (Show other bugs)
rhn508
All Linux
urgent Severity high
: ---
: ---
Assigned To: Sebastian Skracic
Red Hat Network Quality Assurance
us=59468
:
Depends On:
Blocks: 428922
  Show dependency treegraph
 
Reported: 2008-11-10 08:53 EST by Amy Owens
Modified: 2013-01-10 05:27 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-16 07:58:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash dump from my system (2.58 KB, application/octet-stream)
2009-06-11 15:28 EDT, Wes Stupar
no flags Details

  None (edit)
Description Amy Owens 2008-11-10 08:53:24 EST
+++ This bug was initially created as a clone of Bug #470142 +++

Created an attachment (id=322648)
Crash dump of pirut launch

Description of problem:
pirut (pup) crashes on launch with the following message.  
Component: pirut
Summary: TB9536d0ca <string>:64:__iter__:SyntaxError: mismatched tag: line 53386, column 8

This happens no matter how the application is launched.  I have seen this now on two different RHEL5 systems.  Yum and up2date both appear fine, and yum lists the following updates ready for my system.
kernel.i686                              2.6.18-92.1.17.el5     rhel-i386-server
kernel-devel.i686                        2.6.18-92.1.17.el5     rhel-i386-server
kernel-headers.i386                      2.6.18-92.1.17.el5     rhel-i386-server
net-snmp-libs.i386                       1:5.3.1-24.el5_2.2     rhel-i386-server
systemtap.i386                           0.6.2-1.el5_2.2        rhel-i386-server
systemtap-runtime.i386                   0.6.2-1.el5_2.2        rhel-i386-server
tzdata.noarch                            2008i-1.el5            rhel-i386-server


Version-Release number of selected component (if applicable):


How reproducible:
Every time pup is launched, this is happening.  I first noticed this this morning when the updater notification appeared and said that I was no longer getting updates.  When I clicked it, pup started, the window was drawn, and then it crashed.  On the other system I have, I just tried to launch pup from the applications->system tools->Software Updates.  Same crash from command line.

Steps to Reproduce:
1. Launch pup
  
Actual results:
crash

Expected results:
list of available updates.

Additional info:
Yum appears fine.  Ran "yum clean all" hoping it was a cache issue, but not.  "yum check-update" returns the above list of  packages.

--- Additional comment from monkeys_typing@hotmail.com on 2008-11-05 17:36:29 EDT ---

Created an attachment (id=322651)
The pirut generated update list.

--- Additional comment from monkeys_typing@hotmail.com on 2008-11-05 17:39:36 EDT ---

The /var/cache/yum/rhel-i386-server-5/updateinfo.xml.gz file is not being created correctly?  It also generates an error when opening with firefox, at the next location in the file from where pirut errors at.

The version of pirut that is installed on both my machines is:
1.3.28-13.el5

--- Additional comment from monkeys_typing@hotmail.com on 2008-11-05 18:13:44 EDT ---

Upon further inspection (sorry, I'm new at this).  When looking closer at the xml file (go vim), it is this section that pirut is barfing on.

       <reference href="http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=467105" id="467105" type="bugzilla">
        ['xm trigger <domain> init causes kernel panic.']
      </reference>

It appears that both pirut and firefox believe that the bug description has a malformed piece of XML  <domain> instead of an escaped comment.

--- Additional comment from monkeys_typing@hotmail.com on 2008-11-05 19:26:26 EDT ---

I have verified that updating the kernel package that contains the problematic text using yum does indeed "fix" this crash.  However, the mis-parsing/generation of the updateinfo.xml.gz file does appear to be a genuine bug.

--- Additional comment from james.antill@redhat.com on 2008-11-05 23:30:01 EDT ---

Thanks, there isn't anything yum/pirut/etc. can do about this ... reassigning to the RHN people.

--- Additional comment from james.antill@redhat.com on 2008-11-05 23:37:22 EDT ---

*** Bug 470091 has been marked as a duplicate of this bug. ***

--- Additional comment from aowens@redhat.com on 2008-11-06 08:18:18 EDT ---

added user story

http://wwwapps.rdu.redhat.com:8080/xplanner/do/view/userstory?oid=59468

--- Additional comment from james.antill@redhat.com on 2008-11-06 15:27:14 EDT ---

*** Bug 470349 has been marked as a duplicate of this bug. ***

--- Additional comment from wdc@mit.edu on 2008-11-07 15:17:19 EDT ---

I am the Linux Platform Coordinator at MIT, and can report two additional facts about this bug:

1. It also manifests as a scary pop-up message from the software updater applet in the menu bar.  It says that the system is not receiving updates, and tells the user to check the network connection or register for updates. This is going to be VERY upsetting to anyone using Satellite server.

2. This bug will be biting hundreds of desktop RHEL users at MIT.

Please note that we have mentioned this bugzilla in a Service Request, but we don't have a TAM.  Any expedited examination of this bug would be MOST welcome.

-Bill Cattey

--- Additional comment from wdc@mit.edu on 2008-11-07 15:20:53 EDT ---

Question for Jim who originally reported this problem:

Are you getting RHN from a version 4.2 Satellite Server or from some other RHN source?

--- Additional comment from wdc@mit.edu on 2008-11-07 18:05:46 EDT ---

I finally had the software updater applet run.  Here is the actual text of the scary message:

System is not receiving
updates

  Your system is currently not receiving software
  updates.  Please check your network connection
  and/or set up software updates.

                              [Don't notify me again ]

--- Additional comment from monkeys_typing@hotmail.com on 2008-11-07 21:51:24 EDT ---

I (shamefully) have no idea what the details of the Satellite Server that I am connecting to are.  The University of Washington has excellent instructions posted to get a RHEL system connected to their RHN servers.  I have just set up this up and didn't worry about it until it broke.  I have asked for elaboration, and will forward any information as I receive it.
Comment 4 Wes Stupar 2009-06-11 15:28:05 EDT
Created attachment 347463 [details]
Crash dump from my system

This is the crash dump from my attempt to update.
Comment 5 Sebastian Skracic 2010-06-16 07:58:16 EDT
This has been fixed a while ago, together with moving the repomd tasks to Java layer.

Note You need to log in before you can comment on or make changes to this bug.