Bug 470859 - openssh minor annoyance in a spec file
openssh minor annoyance in a spec file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-10 12:05 EST by Michal Jaegermann
Modified: 2009-02-12 10:40 EST (History)
2 users (show)

See Also:
Fixed In Version: openssh-5.1p1-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-12 10:40:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2008-11-10 12:05:04 EST
Description of problem:

There is the following fragment in the package spec:

%if %{WITH_SELINUX}
#SELinux
%patch12 -p1 -b .selinux
%patch13 -p1 -b .mls
%patch16 -p1 -b .audit
%patch17 -p1 -b .inject-fix
%patch18 -p1 -b .pam_selinux
%endif

and patch16, i.e. openssh-4.7p1-audit.patch, modifies configure.ac file.  The trouble is that one of chunks of patch51, i.e. openssh-5.1p1-nss-keys.patch, does that in the same region again and if %{WITH_SELINUX} was set to 0 it fails because configure.ac does not look like expected with one line "missing".

One possible way to fix it would be to have that fragment of patch51 which touches configure.ac in a separate patch with two slightly different variants to be applied conditionally on a state of %{WITH_SELINUX}

Version-Release number of selected component (if applicable):
openssh-5.1p1....

Note You need to log in before you can comment on or make changes to this bug.