Bug 470882 - pyzor's global requirements were not met: type/attribute staff_home_dir_t
pyzor's global requirements were not met: type/attribute staff_home_dir_t
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-10 13:52 EST by Dominick Grift
Modified: 2008-11-10 16:35 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-10 16:35:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominick Grift 2008-11-10 13:52:36 EST
Description of problem:
pyzor's global requirements were not met: type/attribute staff_home_dir_t

looks like the following interface may be causing some issues:

interface(`staff_dontaudit_search_home_dirs',`
	gen_require(`
		type staff_home_dir_t;
	')

	dontaudit $1 staff_home_dir_t:dir search_dir_perms;
')

Version-Release number of selected component (if applicable):
selinux-policy-3.5.13-19.fc10.noarch

How reproducible:
Try to install a policy module:

[root@notebook dgrift]# /usr/sbin/semodule -i dgrift.pp
libsepol.print_missing_requirements: pyzor's global requirements were not met: type/attribute staff_home_dir_t
libsemanage.semanage_link_sandbox: Link packages failed
/usr/sbin/semodule:  Failed!

Steps to Reproduce:
1. cp staff.te dgrift.te; s/staff/dgrift dgrift.te; make -f /usr/share/selinux/devel/Makefile; /usr/sbin/semodule -i dgrift.pp
  
Actual results:
fail

Expected results:
success

Additional info:
Comment 1 Dominick Grift 2008-11-10 13:57:00 EST
by the way if you look in the staff module (staff.if) there are more interfaces that use type "staff_home_dir_t"?
Comment 2 Daniel Walsh 2008-11-10 14:27:34 EST
These are all supposed to be typealias to user_home_dir_t
Comment 3 Daniel Walsh 2008-11-10 14:35:52 EST
I am not seeing this.

rpm -q selinux-policy
selinux-policy-3.5.13-18.fc10.noarch

I built dfript.te from sed of staff.te
Added
staff_dontaudit_search_home_dirs(dgrift_t)


Ran make, semodule and it went successful.
Comment 4 Dominick Grift 2008-11-10 16:03:06 EST
strange i cannot reproduce it. seems to work now. sorry for false alarm.

Note You need to log in before you can comment on or make changes to this bug.