Bug 470891 - Fix fetching FTP urls which don't have .treeinfo available.
Fix fetching FTP urls which don't have .treeinfo available.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
: 471146 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-10 14:20 EST by Cole Robinson
Modified: 2010-10-23 01:47 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:05:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Make sure we actually fetched a usable treeinfo file (1.01 KB, text/plain)
2008-11-10 14:27 EST, Cole Robinson
no flags Details

  None (edit)
Description Cole Robinson 2008-11-10 14:20:21 EST
The mechanism virtinst uses to determine if an FTP file is present in the passed URL tree has apparently been busted all through RHEL5: it always reports success. This just happpened to work out before since most people are installing RHEL or Fedora trees, and we would fall through to those defaults.

With the .treeinfo fetching code for bug 460585, these previously working FTP installs fail, trying to parse a treeinfo file that doesn't exist. This breaks url installs for pre-F8 and pre-RHEL5.2.
Comment 1 Cole Robinson 2008-11-10 14:27:39 EST
Created attachment 323105 [details]
Make sure we actually fetched a usable treeinfo file

Rather than actually fix FTP file detection to work (already upstream), I'd rather not rock the boat. This patch preserves existing behavior, except that we will detect if there really wasn't a treeinfo file fetched, and continue as normal.

Verified that this fetches RHEL5 GA and F10 trees successfully.
Comment 4 Cole Robinson 2008-11-11 15:00:30 EST
Built in python-virtinst-0.300.2-12.el5.
Comment 5 Bryan Mason 2008-11-11 19:29:17 EST
*** Bug 471146 has been marked as a duplicate of this bug. ***
Comment 10 errata-xmlrpc 2009-01-20 16:05:07 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0216.html

Note You need to log in before you can comment on or make changes to this bug.