Bug 470921 - "Barack" and "Obama" are not in /usr/share/dict/words
"Barack" and "Obama" are not in /usr/share/dict/words
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: words (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-10 16:14 EST by John Stracke
Modified: 2009-01-19 11:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 22:08:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
list of all words from names of all American presidents (507 bytes, text/plain)
2008-11-12 05:55 EST, Matěj Cepl
no flags Details

  None (edit)
Description John Stracke 2008-11-10 16:14:04 EST
Description of problem:

"Barack" and "Obama" do not appear in Fedora's wordlist.  It may be considered desirable to be able to spell-check the name of the President of the United States.

Version-Release number of selected component (if applicable):
words-3.0-12.1.fc9.noarch

How reproducible:

Perfectly.

Steps to Reproduce:
1. egrep -i '^(barack)|(obama)$' /usr/share/dict/words
  
Actual results:

No output.

Expected results:

Output should be:

Barack
Obama

Additional info:
Comment 1 John Stracke 2008-11-10 16:23:34 EST
The same problem exists in hunspell-en.  Open Abiword or OpenOffice.org Writer, which use hunspell, and type in "Barack Obama"; both words will be underlined as misspelled.
Comment 2 Matěj Cepl 2008-11-12 05:55:42 EST
Created attachment 323323 [details]
list of all words from names of all American presidents

... and of course, we should include names of all other heads of states in the world ( preferably for the past couple of thousand years).
Comment 3 Martin Stransky 2008-11-12 05:58:38 EST
Many of those names are in the list (even some Czech presidents - Masaryk, Benes, Gottwald, Havel, Klaus...)
Comment 4 David Tardon 2008-11-12 06:19:28 EST
Maybe we should include names of all persons who ever lived on Earth? Plus names of all fictional persons, to be on the safe side?
Comment 5 John Stracke 2008-11-12 08:25:02 EST
(In reply to comment #4)
> Maybe we should include names of all persons who ever lived on Earth?

The word list is based on probability.  "Floccinaucinihilipilification" is a word, but it's not in the list, because it's less likely to be used than, say, "flashlight".  Similarly, "Barack" and "Obama" are much more likely to be used than they were a year ago.
Comment 6 David Tardon 2008-11-12 09:05:26 EST
(In reply to comment #5)
> (In reply to comment #4)
> > Maybe we should include names of all persons who ever lived on Earth?
> 
> The word list is based on probability.  "Floccinaucinihilipilification" is a
> word, but it's not in the list, because it's less likely to be used than, say,
> "flashlight".  Similarly, "Barack" and "Obama" are much more likely to be used
> than they were a year ago.

Hardly... How probable is usage of words as 'superincomprehensibleness' or 'pneumonoultramicroscopicsilicovolcanoconiosis' (the longest word in the file; is it really _one_ word?), if one doesn't want one's writing to be superincomprehensible?
Comment 7 John Stracke 2008-11-12 12:42:22 EST
It's harmless if the file contains some improbable words, but it *needs* to contain probable words.

Why is there an argument here? It seems stupid to put out a spelling checker that doesn't know the name of the US President.  And, yeah, the US is only one country; but I'd favor adding the names of other countries' leaders, too.  I suppose you could make an argument that it's not worth of putting in the name of the leader of East Elbonia, but we're talking about an English word list and the leader of the largest English-speaking country.
Comment 8 Jon Masters 2008-12-15 14:31:21 EST
What's the problem with just adding these words to the dictionary?
Comment 10 Karel Zak 2009-01-12 06:22:24 EST
I have added a new file with US presidents to the words (thanks to Matej, comment #2) ... it's simple to add a new name now.
Comment 11 Fedora Update System 2009-01-12 08:11:18 EST
words-3.0-13.1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/words-3.0-13.1.fc10
Comment 12 Fedora Update System 2009-01-14 22:08:08 EST
words-3.0-13.1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Jon Masters 2009-01-18 21:54:15 EST
Nice. Hopefully it'll push in time for Tuesday.
Comment 14 John Stracke 2009-01-19 11:35:58 EST
(In reply to comment #13)
> Nice. Hopefully it'll push in time for Tuesday.

In fact, it's already pushed; I updated yesterday, and "Barack" and "Obama" are now in words.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.