Bug 47096 - XFree86 broken on DVD install
XFree86 broken on DVD install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-03 02:18 EDT by Need Real Name
Modified: 2007-04-18 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-11 05:22:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-03 02:18:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
I can't configure the xfre86, with a vodoo3 and Philips 107E Monitor

How reproducible:
Always

Steps to Reproduce:
1.Run Xconfigurator
2.Xconfigurator see Vodoo3 and Philips 107E Monitor components
3.No finish the configuration
	

Actual Results:  No finish teh configuration

Expected Results:  configure free86 and run startx (windows desktop)

Additional info:
Comment 1 Alexei Podtelezhnikov 2001-07-03 03:53:10 EDT
Is this after you updated Xconfigurator, and mouseconfig, and everything else 
from ftp://ftp.redhat.com/pub/redhat/linux/updates/7.1 ... ?
Comment 2 Need Real Name 2001-07-04 01:43:52 EDT
I tried update Xconfigurator and mouseconfig, but rpm answer:
"error: failed dependencies: Xfree86 >= 4.0.2 is needed by Xconfigurator-4.9.29-
1"

Now i try update all updates in 
ftp://ftp.redhat.com/pub/redhat/linux/updates/7.1

Comment 3 Need Real Name 2001-07-06 01:45:14 EDT
	I, download all the updates for RedHat v7.1, and run:

	Rpm  -Fvh *.rpm

	Rpm answer:

	Xfree86 >= 4.0.2 is needed by Xconfigurator-4.9.29-1
	Kdelibs = 2.1.2 is needed by kdelibs-devel-2.1.2-1
	Kdelibs = 2.1.2 is needed by kdelibs-sound-2.1.2-1
	LibDcop.so.1  is needed by kdelibs-sound-2.1.2-1
	Libkdecore.so.3 is needed by kdelibs-sound-2.1.2-1
	Libkdefakes.so.3 is needed by kdelibs-sound-2.1.2-1
	Libkdeui.so.3 is needed by kdelibs-sound-2.1.2-1
	Kdelibs = 2.1.2 is needed by kdelibs-sound-devel-2.1.2-1
	Samba-common = 2.0.10 is needed by samba-client-2.0.10-2

	And then i found the version of rpms in the redhat v7.1 cd, and they 
are an older version.

Comment 4 Mike A. Harris 2001-07-06 22:51:27 EDT
What do the following commands report:

rpm -qa |grep XFree86|sort

rpm -q redhat-release
Comment 5 Need Real Name 2001-07-09 02:10:42 EDT
Sorry, i am mistaken with redhat Xfree86 RPMs version, the version of Xfree is 
4.0.3.

I have installed a Custom system and when i run !'rpm !Vqa | grep !%Xfree86!&, i 
get:

Xfree86-libs-4.0.3-5
Xfree86-xfs-4.0.3-5
Xfree86-tools-4.0.3-5
Xfree86-xdm-4.0.3-5
Xfree86-devel-4.0.3-5
Xfree86-75dpi-fonts-4.0.3-5
Xfree86-twm-4.0.3-5
Xfree86-100dpi-fonts-4.0.3-5

Then, i tried install a new workstation installation, with all default 
settings, and i got identically results. When i run !'rpm !Vqa | grep !%Xfree86!&, 
i get:

Xfree86-libs-4.0.3-5
Xfree86-xfs-4.0.3-5
Xfree86-tools-4.0.3-5
Xfree86-xdm-4.0.3-5
Xfree86-devel-4.0.3-5
Xfree86-75dpi-fonts-4.0.3-5
Xfree86-twm-4.0.3-5
Xfree86-100dpi-fonts-4.0.3-5
Xfree86-FBDev-3.3.6-35

And when i try update the Xconfigurator rpm, i get the same results:

	!'Error in dependences:

	Xfree86 >= 4.0.2 is needed by Xconfigurator-4.9.29-1!(

Then, i installed a !'Custom system installation!(, another time. The settings i 
select, are:

	English installation
	Spanish keyboard
	English lenguage (USA)
	Automatically partition and remove Data
	No firewall
	Package group selection:

		Printer support
		X windows system
		GNOME
		KDE
		Mail/www/news tools
		Dos/windoes connectivity
		Graphics manipulation
		Games
		Multimedia support
		Netkorked workstation
		Dialup workstation
		Network management workstation
		Emacs
		Development
		Kernel development
		Utilities

	Installations found Voodoo3 (Generic) 16 MB and DDC probed Monitor- 
PHL0004 (30-70 Khz !V 50-160 Khz)

	Color:	High color (16 bit) 	1024x768 of resolution
	Default desktop:  GNOME
	Login: text

	When i run !'rpm !Vqa | grep !%Xfree86!&, i get:

Xfree86-libs-4.0.3-5
Xfree86-xfs-4.0.3-5
Xfree86-tools-4.0.3-5
Xfree86-xdm-4.0.3-5
Xfree86-devel-4.0.3-5
Xfree86-75dpi-fonts-4.0.3-5
Xfree86-twm-4.0.3-5
Xfree86-100dpi-fonts-4.0.3-5

	And when i run !'rpm !Vq redhat-release!(, i get:

	Redhat-release-7.1-1

	When i run Xconfigurator, finish the configuration with error.

when i try update the Xconfigurator rpm, i get the same results:

	!'Error in dependences:

	Xfree86 >= 4.0.2 is needed by Xconfigurator-4.9.29-1!(

	When i run !'startx!(, i get:

	Startx # XIO: fatal IO error 104 (Connection reset by peer) on X 
server !':0.0!( after 0 request (0 know processed) with 0 events remaining.




Comment 6 Alexei Podtelezhnikov 2001-07-09 17:05:38 EDT
Something is really weird going on here. How did you miss the most important 
rpm - XFree86-4.0.3-5.i386.rpm? Can you see this exact RPM on your CD? Yes, 
it's the largest, but is the most important part. Basically, you don't have 
drivers installed whatsoever. Can you install this exact file manually? It is 
surprising that your installation didn't comlain about it while checking 
dependencies before installation.

Now the questions... Did you burn CD from official ISO images? Can you try the 
network installation from one of the official mirrors?
Comment 7 Need Real Name 2001-07-11 03:17:52 EDT
I have got find the problem.

I have an oficial RedHat Linux 7.1 Professional edition, but im still not 
registered.

In the distribution of RedHat Linux 7.1, there are 10 cds, 1 dvd and 1 cd 
sysadmin. The RPM Xfree86-4.0.3-5.i386.rpm exist in the CD and DVD, but i 
installed the linux operating system from DVD with  problems, finally i tried 
install the linux operating system with CD, without any problem.

Comment 8 Patrick C. F. Ernzer 2001-07-11 05:22:26 EDT
The problem is indeed with the DVD, see <http://www.europe.redhat.com/newdvd/>
for detailled information.

If you supply your product id (on the registration card that came with your Red
Hat Linux 7.1 Professional) in the form on the page, you will be able to order a
 replacement DVD.

Broken DVD have the following number on them:  CDR0035EU
Working DVD have the following number on them: CDR0035EU-A
Comment 9 Mike A. Harris 2001-07-31 03:49:43 EDT
None of the bugzilla resolutions exist for "BROKENDVDASKUSFORNEWONE" so
I chose CURRENTRELEASE arbitrarily as it sounded nicest. ;o)

Anyone having this prob, follow the above URL for a new DVD, etc..

Note You need to log in before you can comment on or make changes to this bug.