Bug 47104 - SNMP agent returns wrong uptime
Summary: SNMP agent returns wrong uptime
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-03 09:42 UTC by Michal Žejdl
Modified: 2015-03-05 01:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-09 10:38:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Žejdl 2001-07-03 09:42:30 UTC
Description of Problem:

SNMP agent returns wrong uptime. After 24th day uptime jumps to 472 days
(roughly 496 - 24),
then goes on and after 496 jumps back to 0 (as I expected).

I saw this problem on all 7.1 instalations, so IMHO reproducion (via date)
can be easy.

Comment 1 Phil Knirsch 2002-01-29 14:07:59 UTC
The latest version (4.2.3) is available via rawhide now. This should fix this
problem.

Thanks,

Read ya, Phil


Comment 2 Michal Žejdl 2002-02-27 12:42:02 UTC
Sorry, but ucd-snmp-4.2.3-5 from rawhide doesn't help. Problem persists. U used
ucd-snmp-4.2.3-5.src.rpm on RH 7.2 (where I moved), because of huge
dependencies.

The problem is in both 7.1 and 7.2.

Any suggestions?

Comment 3 Phil Knirsch 2002-02-27 12:47:33 UTC
I have looked at the piece of code where the uptime gets calculated and i guess
that there might be some kind of overflow happening.

I'll try to look into it in the next rawhide release.

Read ya, Phil

Comment 4 Phil Knirsch 2002-04-09 13:06:58 UTC
OK, it seems as if the update to 4.2.4 fixes this problem, at least i the output
now looks ok for a:

  snmpwalk localhost public host.hrSystem.hrSystemUptime.0

If you could verify this, then i can close this bug.

Thanks,

Read ya, Phil

Comment 5 Michal Žejdl 2002-04-22 09:03:37 UTC
I try ucd-snmp-4.2.4.pre3-4 from rawhide, but I must say, that problem doesn't
disappear. How I test it: snmpd start, check uptime (Timeticks: (4000)
0:00:40.00), move to May 23 (date 05231041), check uptime (Timeticks:
(4133329988) 478 days).


Comment 6 Phil Knirsch 2002-06-26 09:42:42 UTC
OK, verified again myself. It's not host.hrSystem.hrSystemUptime.0 but
system.sysUpTime.0

It's fixed in net-snmp-5.0.1, i'm currently looking in either updating to the
new major release or to backport the changes to 4.2.5.

Will let you know here.

Read ya, Phil

PS: After about 497 days there will be an overflow, no matter what, as the
system.sysUpTime.0 is an integer and is represented in 1/100 sec resolution, but
i guess that is acceptable.

Comment 7 Phil Knirsch 2003-12-09 10:38:33 UTC
OK, an errata has been released with the fix.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.