Bug 471082 - telnet not answering
telnet not answering
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 472453 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-11 12:47 EST by Janina Sajka
Modified: 2009-01-06 13:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-18 15:12:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Janina Sajka 2008-11-11 12:47:16 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:Responding "connection refused."
Comment 1 David Cantrell 2008-11-11 17:36:23 EST
Can you give me more information on how you started the installation exactly?
Comment 2 Janina Sajka 2008-11-11 20:28:36 EST
Yes, sorry. I specify the command 'text telnet dhcp ksdevice=aa:bb:cc:dd:ee:ff' . I have tried this on two machines with multiple nics, therefore the ksdevice. I wait for the target machine to respond to ping, then telnet to it.
Comment 3 David Cantrell 2008-11-11 20:44:37 EST
(In reply to comment #2)
> Yes, sorry. I specify the command 'text telnet dhcp ksdevice=aa:bb:cc:dd:ee:ff'
> . I have tried this on two machines with multiple nics, therefore the ksdevice.
> I wait for the target machine to respond to ping, then telnet to it.

Try booting with:

    text telnet ip=dhcp ksdevice=aa:bb:cc:dd:ee:ff
Comment 4 Janina Sajka 2008-11-12 10:50:58 EST
Same result. However, the dhcp isn't the problem. I can see the address being assigned in /var/log/messages. And, as noted above, I wait for a ping response before telnetting.
Comment 5 David Cantrell 2008-11-20 17:07:29 EST
*** Bug 472453 has been marked as a duplicate of this bug. ***
Comment 6 Bug Zapper 2008-11-26 00:12:24 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 David Cantrell 2008-12-18 15:12:58 EST
Fix will be in anaconda-11.4.1.59-1.
Comment 8 David Cantrell 2008-12-18 17:35:24 EST
Correction, will be fixed in anaconda-11.5.0.1-1.
Comment 9 Janina Sajka 2008-12-19 21:51:13 EST
Just tried with Anaconda 11.5.0. Unfortunately, an ip isn't being requested over dhcp.
And, if I try specifying ip=[addr], the machine doesn't appear to accept the address. It doesn't
respond to ping. Note that I have tailed /var/log/messages on the dhcp server to
ascertain that no address is requested over dhcp. So, maybe telnet is OK now,
but I'm a step short of that over dhcp or static address specification.
Comment 10 David Cantrell 2008-12-22 15:01:09 EST
You're seeing a different bug now, not related to the telnet fix.
Comment 11 Janina Sajka 2009-01-06 12:34:03 EST
OK. So is it possible to have the fix in Anaconda-1.4.x, please? I need to do remote installs, and vnc isn't a workable option. I can't be the only one with this problem. Would be very helpful as there's no other way with F10.
Comment 12 Chris Lumens 2009-01-06 13:23:11 EST
We don't do official updates for the anaconda package, so backporting this fix doesn't really make much sense.  Occassionally, the Fedora Unity project does make updated media that includes a newer anaconda, but this is nothing we officially regularly do.  So it's really best not to rely on that.

Note You need to log in before you can comment on or make changes to this bug.