Bug 471083 - Some icons cannot be changed in KDE4
Some icons cannot be changed in KDE4
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-11 12:52 EST by John Griffiths
Modified: 2008-11-11 13:40 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-11 13:23:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 167031 None None None Never

  None (edit)
Description John Griffiths 2008-11-11 12:52:00 EST
Many of the icons cannot be changed. Some files like a doc file from Microsoft comes up with a ? icon. I select the file and properties and the wrench icon to edit and then try to select the icon and nothing happens.

I am using Fedora-KDE which I am told is compatible with KDE4.

I have tried to change the ICON using Dolphin and Konqueror.

This also happens with sxw extent files which are the old OpenOffice format files. Again, it is correctly identified but a ? icon is used and cannot be changed.
Comment 1 Rex Dieter 2008-11-11 12:59:06 EST
I didn't know one could change mimetype icons *at all*.  How?
Comment 2 Rex Dieter 2008-11-11 13:03:24 EST
afaik, the wrench icon is to for changing mimetype properties like:
file name patterns
Application preference

but changing icon isn't possible.

Fwiw, .doc files on my box get a valid icon, but .docx do get '?'.
Comment 3 Rex Dieter 2008-11-11 13:05:28 EST
So, I guess the bug here is simply mimetypes with missing icons?
Comment 4 John Griffiths 2008-11-11 13:12:43 EST
In KDE3, I can click on the ICON and change the icon to any icon I want even if it does not make sense. The icons that come up by default are mime-type icons.
Comment 5 John Griffiths 2008-11-11 13:14:13 EST
This is a case of the application "knowing" what I want to do "better" than I do.

Windows does that. Linux didn't and shouldn't in my opinion.
Comment 6 Rex Dieter 2008-11-11 13:23:18 EST
KDE3 used it's own system for mimetypes.  KDE4 (now) uses a common spec which is shared among several/most desktops (including gnome, xfce).  I'd hope you'd agree this is a "good thing"(tm).

Looks like kde4 currently lacks the feature you're looking for (changing mimetype icons).  This isn't something we can fix easily in fedora-land. (marking CANTFIX).

Feel free to request it upstream @ bugs.kde.org.  (When/if you do please, let us know, so we can track the upstream feature request).
Comment 7 John Griffiths 2008-11-11 13:32:53 EST
Already reported upstream.  https://bugs.kde.org/show_bug.cgi?id=167031
Comment 8 Rex Dieter 2008-11-11 13:40:36 EST
thanks!

Looks like a good chance of this landing for kde-4.2.x

Note You need to log in before you can comment on or make changes to this bug.