Bug 471086 - Add Broker Link and Add Route are wrongly reporting failure status.
Add Broker Link and Add Route are wrongly reporting failure status.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: cumin (Show other bugs)
1.1
All Linux
medium Severity low
: 1.1
: ---
Assigned To: messaging-bugs
Frantisek Reznicek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-11 13:07 EST by Ernie
Modified: 2015-11-15 19:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 13:49:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ernie 2008-11-11 13:07:38 EST
After calling link.bridge (for adding a new broker link or for adding a new route to a broker link) the response reports "Failed: K". However the call succeeds.

cumin r2776


How reproducible:
Add a broker link or route and view the Actions popup.

Steps to Reproduce:
1. connect to mrg2.lab.bos.redhat.com
2. click on the Messaging tab
3. click on the Broker Links tab
4. click on the 'Add Broker Link' button
5. fill in the form with a valid broker or use localhost:9999
6. click submit on the form
7. wait a few secs
8. click on the Actions line in the upper right-hand part of page

  
Actual results:
The status for the 'Add Broker Link' line will be 'Failed: K'

Expected results:
The status for the 'Add Broker Link' line should be 'Completed'

Additional info:
A theory is that the normal status of 'OK' is getting mangled somewhere along the way and only the 'K' is coming through. This is being treated as an error.
Comment 1 Ernie 2008-11-17 13:49:26 EST
Closed. This was not a bug. It was mismatch between the libraries I was using and the libraries on mrg2.

Note You need to log in before you can comment on or make changes to this bug.