Bug 471104 - SELinux is preventing printers.cgi (cupsd_t) "connectto" to /var/run/cups/cups.sock (unconfined_t).
SELinux is preventing printers.cgi (cupsd_t) "connectto" to /var/run/cups/cup...
Status: CLOSED DUPLICATE of bug 471116
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-11 15:04 EST by morgan read
Modified: 2008-11-14 07:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-14 07:21:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
setroubleshoot text (2.68 KB, text/plain)
2008-11-11 15:04 EST, morgan read
no flags Details

  None (edit)
Description morgan read 2008-11-11 15:04:33 EST
Created attachment 323228 [details]
setroubleshoot text

Description of problem:
See selinux_alert.txt attached

Version-Release number of selected component (if applicable):
[root@morgansmachine ~]# rpm -q cups
cups-1.3.9-1.fc8

How reproducible:
Seems always 

Steps to Reproduce:
1.open http://localhost:631/printers/
2.
3.
  
Actual results:
Error:

    {error}

Expected results:
No error

Additional info:
Comment 1 Tim Waugh 2008-11-12 04:56:28 EST
The file /var/run/cups/cups.sock has the wrong SELinux file context.  Please remove it ('rm /var/run/cups/cups.sock') and try again.  The file will get created again.

If the problem still occurs, please show me the output of this command:

ls -Zd /var/run/cups
Comment 2 Tim Waugh 2008-11-14 07:21:40 EST
Same root cause as bug #471116.

*** This bug has been marked as a duplicate of bug 471116 ***

Note You need to log in before you can comment on or make changes to this bug.