This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 471114 - "error occurred while loading or saving configuration information" (CORBA, Gconf?)
"error occurred while loading or saving configuration information" (CORBA, Gc...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: GConf2 (Show other bugs)
9
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-11 15:55 EST by D. Wagner
Modified: 2009-02-13 15:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 15:59:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
First screenshot: shows both dialog box (in middle of screen) and notification box (in lower right) (61.97 KB, image/png)
2008-11-23 23:20 EST, D. Wagner
no flags Details
Second screenshot: shows dialog box (in middle of screen) but no notification box (59.29 KB, image/png)
2008-11-23 23:21 EST, D. Wagner
no flags Details
After re-installing gconf schema files, running yum-complete-transactions, and rebooting, here is what I see when I log in (133.37 KB, image/png)
2008-11-25 20:32 EST, D. Wagner
no flags Details

  None (edit)
Description D. Wagner 2008-11-11 15:55:30 EST
Description of problem:

When I log in, I get two dialog boxes with error messages:

Dialog box #1: "An error occurred while loading or saving configuration information for firefox. Some of your configuration settings may not work properly." with buttons for Details and OK.  Clicking Details says:

Adding client to server's list failed, CORBA error: IDL:omg.org/CORBA/COMM_FAILURE:1.0
Adding client to server's list failed, CORBA error: IDL:omg.org/CORBA/COMM_FAILURE:1.0
Adding client to server's list failed, CORBA error: IDL:omg.org/CORBA/COMM_FAILURE:1.0
Adding client to server's list failed, CORBA error: IDL:omg.org/CORBA/COMM_FAILURE:1.0

Dialog box #2: "An error occurred while loading or saving configuration information for Power Manager. Some of your configuration settings may not work properly."  with buttons for Details and OK.  Clicking Details says:

Adding client to server's list failed, CORBA error: IDL:omg.org/CORBA/COMM_FAILURE:1.0



Version-Release number of selected component (if applicable):

libbonoboui-2.22.0-2.fc9.x86_64
libbonoboui-2.22.0-2.fc9.i386
libbonobo-2.22.0-2.fc9.i386
libbonobo-2.22.0-2.fc9.x86_64
GConf2-2.22.0-1.fc9.x86_64
gconf-editor-2.22.0-1.fc9.x86_64
GConf2-2.22.0-1.fc9.i386
GConf2-gtk-2.22.0-1.fc9.x86_64

This is on a Fedora 9 system, fully updated.  It was initially a fresh Fedora 9 install (i.e., not an upgrade from a prior Fedora release).  I've gotten these kinds of dialog boxes for a long time but haven't gotten around to reporting it.  x86_64, Lenovo x61.
Comment 1 D. Wagner 2008-11-23 21:05:26 EST
Is there any information I can provide to help troubleshoot this?
Comment 2 Ray Strode [halfline] 2008-11-23 21:41:36 EST
what's the output of ps -ef | grep dbus-daemon ?

Are you logging in from runlevel 3, or gdm (the default graphical login), or some other way?

does it happen every time or sporadically?
Comment 3 D. Wagner 2008-11-23 21:50:38 EST
$ ps -ef | grep dbus-daemon
daw       2141  4581  0 10:47 pts/0    00:00:00 grep dbus-daemon
dbus      2392     1  0 Nov22 ?        00:00:22 dbus-daemon --system
daw       3006     1  0 Nov22 ?        00:00:00 /bin/dbus-daemon --fork --print-pid 7 --print-address 9 --session

(I'm logged in as user 'daw'.)

I'm logging in from gdm (the graphical login).  I boot and it automatically starts up gdm; I log in from gdm.

It happens every time I log in, as far as I can tell.  Each time I log in I get two or three such dialogue boxes, each with a CORBA error; I haven't checked carefully whether it is always for the same set of applications.  It's plausible it might be related to what applications I had open when I shut down last (as Gnome tries to restart some of those applications, such as gnome-terminal).
Comment 4 D. Wagner 2008-11-23 23:19:56 EST
I have some more information that might help.

1) If I reboot, and then log in via gdm:

   I reliably get one or more dialog boxes saying "An error occurred while loading or saving configuration information for [XXX]".  The program ("XXX") varies: sometimes it's gnome-terminal, sometimes clock-applet, maybe other things.  Sometimes I get two such dialog boxes.  Clicking on "Details" in that dialog box always refers to CORBA errors.  Sometimes I also get a notification box in the lower-right corner saying "Install problem!" but that happens only some of the time.

2) If I log out, then log in again via gdm:

   I get no dialog boxes, no notification boxes, no errors.


So it seems these issues *only* arise on the first login after booting.  If I reboot, log in, log out, and log in again, I'll see the errors on the first login but not in the second login.

The output of "ps -ef | grep dbus-daemon" doesn't seem to vary in any obvious way between these two cases (it seems about the same whether it's the first login or not).

I'm attaching two screenshots that are reasonably representative of what I see if I reboot and then log in via gdm.  The first shows both a dialog box as well as a notification box in the lower-right corner of the screen.  The second shows just a dialog box but no notification box.  I hope this helps.
Comment 5 D. Wagner 2008-11-23 23:20:58 EST
Created attachment 324453 [details]
First screenshot: shows both dialog box (in middle of screen) and notification box (in lower right)
Comment 6 D. Wagner 2008-11-23 23:21:39 EST
Created attachment 324454 [details]
Second screenshot: shows dialog box (in middle of screen) but no notification box
Comment 7 Ray Strode [halfline] 2008-11-24 10:05:06 EST
ah ha, the notification pop up is telling.

It suggests that some of your gconf schemas aren't fully installed.  This could have happened if (for instance) the power went out or your battery died in the middle of an update.

If you don't mind, there are two things I'd like you to try.

(from a root shell)
export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
for f in /etc/gconf/schemas/*.schemas; do gconftool-2 --makefile-install-rule $f; done

This will reinstall all of the systems schema files.  It's going to take some time and print a lot of things on the screen, but afterwards your system may work a lot better.

The second thing I'd like you to try is running

yum-complete-transaction

that will finish the last pending transactions that may have gotten cut short.

You may need to run this command multiple times, if there are multiple failed transactions.

After doing those things, do you still see a problem?
Comment 8 D. Wagner 2008-11-25 20:30:37 EST
Thanks for your help.  I did both things.  Reinstalling the system schema files did indeed lead to lots of output but appeared to complete successfully.  Running yum-complete-transaction told me there were no pending transactions.  After doing this, I rebooted and logged in again, but still got all the strange notifications/error dialogues.  I'll attach another screenshot (Screenshot4.png).

Sorry about all this!  Am I the only one seeing this issue?  Should I just give up and live with the error messages?  I hate to take up your time on this if I'm the only one seeing it -- I'm sure there are any number of other valuable ways you could be contributing....
Comment 9 D. Wagner 2008-11-25 20:32:04 EST
Created attachment 324684 [details]
After re-installing gconf schema files, running yum-complete-transactions, and rebooting, here is what I see when I log in
Comment 10 Ray Strode [halfline] 2008-12-01 11:04:15 EST
right now you are the only one seeing this problem.

How long does log in normally take? Early in the login process the first thing to use gconf calls its GetIOR() method over the message bus which will cause gconfd to get started, the method invoked, and the result returned back to the client so the client can talk to gconf over CORBA.

I believe there's a 15 second timeout on that GetIOR() method.  It could be that you're hitting it.
Comment 11 D. Wagner 2008-12-02 19:14:27 EST
OK, I took some timings and your conjecture looks plausible.

I just timed in a login process.  Here are the basic events & the time at which I saw them:

I enter my username and password but do not press enter yet
E1: I hit enter in the password prompt, starting the process
E2: The first "An error occurred while loading or saving configuration..." dialogue box appears
E3: A pair of notification pop-ups appear for the first time
E4: Session startup appears to be fully finished & all apps re-started

Here are approximate timestamps for these events (taken on another machine, recorded manually):

E1: 15:54:03
E2: 15:54:21
E3: 15:54:24
E4: 15:54:32

So the time duration is roughly: E1->E2: 18 seconds, E1->E3: 21 seconds, E1->E4: 28 seconds.

This is on a Lenovo X61 laptop plugged into AC (/proc/cpuinfo says its a dual-core Core 2 Duo T7300 @ 2GHz) and with a fast hard disk (7200rpm) -- relatively modern kit, in case that helps calibrate your expectations for how fast it *ought* to boot.

I just logged out and logged back in, without rebooting in between, and here's what I saw:

I enter my username and password but do not press enter yet
F1: I hit enter in the password prompt, starting the process
F2: Some of my apps appear
F3: A "An error occurred while loading or saving configuration information for firefox" dialogue box appears
F4: All apps appear have been re-started successfully

With timestamps (recorded manually, so as before, beware of the possibility for small errors):

F1: 16:04:41
F2: 16:04:47
F3: 16:04:50
F4: 16:04:51

This means F1->F2 is 6 seconds, F1->F3 is 9 seconds, F1->F4 is 10 seconds.  This certainly consistent with your conjecture about the possibility of hitting a 15 second timeout.

Note that, strangely, I did get one "configuration" error dialog box (referring to CORBA errors) this time when logging in for a second time -- something I don't remember seeing before.  So this seems to contradict my earlier report that I only see these configuration errors the first time I log in.  On the other hand I didn't see any notification pop-ups nor any dialogue boxes for gnome-terminal/clock-applet this time.  I don't know what this means, except that maybe my earlier reports should not be treated as reliable, as it seems this is not entirely deterministic?

If you'd like me to try further tests to determine whether I might be hitting some issue with the GetIOR() timeout, I'd be happy to do that.  In that case I may need some suggestions about how to go about debugging it.  Should I try booting, logging into a text console, starting some shell script to do a "while true; do ps auxw; sleep 1; done > log" and upload the result?  Would that be helpful?  Is there something you would find helpful?  I could try running strace on gconf if you can suggest how to script it up to automatically run strace on the right pid (it seems the time window may be a bit too short to do this by hand between the time when I enter my password and when the dialogue boxes pop up) -- I'm comfortable writing shell scripts & C programs but I'm not too sure what processes to look for or what processes I should be tracing and how to recognize them in a shell script and when they get started, so I could use some guidance if you'd like me to troubleshoot further.

Alternatively, if you feel this is not worth pursuing further, that's fine with me too (as I'm the only one seeing this I don't know whether this is worth your time).
Comment 12 Ray Strode [halfline] 2008-12-03 09:25:06 EST
i can try doing a scratch build that removes the timeout and we can see if that helps.
Comment 13 Ray Strode [halfline] 2008-12-03 09:46:21 EST
Hmm, looks like I was on the wrong track with the GetIOR call.

I didn't actually add that call until the beginning of the F10 development period, so that timeout isn't your issue.
Comment 14 Ray Strode [halfline] 2008-12-03 09:55:38 EST
Do you have something that modifies /tmp during login?

Prior to the GetIOR() method getting added, communication between clients and the configuration daemon was established through a file in /tmp.  If that file gets corrupted or made unreadable during login I could see it causing this sort of issue.
Comment 15 D. Wagner 2008-12-03 21:36:17 EST
Hmm, I can't seem to find anything that would modify /tmp during login.  I checked my login scripts (.zshrc etc) and see nothing in there that would do this (I can imagine temporary files getting created, but presumably under a unique name, so they shouldn't corrupt other files).  A "ls -lat /tmp" before and after logging in didn't show anything obvious.  On a whim, I blew away every file under /tmp, then rebooted and logged in again; I still get the dialog boxes.

But hey, maybe there's something about my customization that is causing some problems; it could be.  I can't think what, but that doesn't mean there isn't something.

Thanks for all the brainstorming.

This is starting to sound like an endless maze... Perhaps I ought to wait for F10, then wipe my hard disk, do a clean install of F10 from scratch, and see if I still get these dialog boxes/pop-ups after a clean install, to rule out the possibility of some kind of local customization being to blame, and to get a clean bug report if the issue still persists?
Comment 16 Ray Strode [halfline] 2008-12-04 09:48:06 EST
If you want to give F10 a try before doing a reinstall and you have a usb stick with a gb or more, you could try the live image:

http://download.fedoraproject.org/pub/fedora/linux/releases/10/Live/i686/F10-i686-Live.iso

http://docs.fedoraproject.org/install-guide/f10/en_US/sn-making-media.html
Comment 17 Ray Strode [halfline] 2008-12-04 09:52:35 EST
(above links from http://get.fedoraproject.org)
Comment 18 D. Wagner 2009-02-13 15:59:29 EST
After reformatting my laptop's hard drive and a clean install of F10, I can no longer reproduce this bug.  Therefore, I am going to close this bug.  Thanks for your help.

Note You need to log in before you can comment on or make changes to this bug.