Bug 471120 - Release notes do not accurately describe transition of Radeon drivers out of Technical Preview.
Release notes do not accurately describe transition of Radeon drivers out of ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Documentation (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ryan Lerch
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-11 16:15 EST by wdc
Modified: 2010-12-01 20:36 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-22 20:08:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wdc 2008-11-11 16:15:11 EST
Description of problem:

The email sent out to rhelv5-announce and rhelv5-beta describing the 
feature set of RHEL 5.3 says that the ATI Radeon r400/r500 drivers are now
fully supported and no longer part of a Technology Preview.

Installing the RHEL 5.3 Beta DVD confirms this fact.

The current Beta Release Notes, however, still says that radeon_tp is the driver and that it is still in Technology Preview.

Presumably this is being taken care of in an as yet un-published draft of the Release Notes.  Inasmuch as the Radeon R500 driver is very important to MIT, I want to make sure that the MIT customers I serve see this important milestone
in the release notes.

-William Cattey
Linux Platform Coordinator
Massachusetts Institute of Technology.

P.S. Kudos to the folks who integrated the R500 driver.  My preliminary testing shows it much more solid than what was installed as radeon_tp in RHEL 5.2.
Comment 1 wdc 2009-02-23 22:41:44 EST
How sad that NINETY days went by before this bug was assigned.
RHEL 5.3 went to the field and the problem I reported in the release notes
WAS NOT FIXED.

I expect that documentation issues were prioritized behind technical issues.
Even so, Red Hat can do better.

The hard work of the folks that did the integration of Radeon DID NOT GET CREDIT because the Release Notes shipped without the correct information.

Red Hat MUST do better!
Comment 5 wdc 2009-07-01 12:30:01 EDT
After four months, nobody seems to understand the concern I am raising.
I apologize for not being clearer, and for not, until now supplying actual prose:

If the Release notes are to accurately reflect reality, the prose at:
http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/Release_Notes/sect-Release_Notes-Driver_Updates.html
should change from:

   The radeon_tp driver is now fully supported in this release.

to:

    The radeon_tp driver that appeared as a technology preview is now fully
    supported in this release and has been renamed to "radeon".

People looking for radeon_tp as a fully supported driver WILL NOT FIND ONE
because the driver has been renamed to the proper upstream name.  This REALLY SHOULD be reflected in the release notes, and this tiny issue should have been spotted by someone at Red Hat in the proofreading back in November 2008.

It is my hope that I have provided clarity and a useful amendment to the notes.

Note You need to log in before you can comment on or make changes to this bug.