Bug 471146 - [5.3Beta][REG] Cannot install older PVguest(RHEL5.1, 5.0, 4,7, 4.6) via virt-install
[5.3Beta][REG] Cannot install older PVguest(RHEL5.1, 5.0, 4,7, 4.6) via virt...
Status: CLOSED DUPLICATE of bug 470891
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-11 19:21 EST by Bryan Mason
Modified: 2009-12-14 16:02 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-11 19:29:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Mason 2008-11-11 19:21:25 EST
Description of problem:

  Using virt-install to install:
  a) a paravirtualized guest
  b) older than RHEL 5.2
  c) using FTP as an installation method

  will result in an exception.

Version-Release number of selected component (if applicable):

  python-virtinst-0.300.2-11.el5

How reproducible:

  Every time.

Steps to Reproduce:

  Run a command like:

    virt-install --debug --paravirt --name=it236056 \
    --ram=256 --file=/var/lib/xen/images/it236056-disk0 \
    --nographics \
    --location=ftp://why.sjc.redhat.com/pub/ks_mirror/rhel-5-server_u1_x86_64
  
Actual results:

  Starting install...
  Tue, 11 Nov 2008 15:53:37 DEBUG    Fetching URI 
  ftp://why.sjc.redhat.com/pub/ks_mirror/rhel-5-server_u1_x86_64/.treeinfo
  Tue, 11 Nov 2008 15:53:37 DEBUG    Saved file to 
  /var/lib/xen/virtinst-.treeinfo.dSyNSJ
  Retrieving file .treeinfo...                                       0 B 00:00
  Tue, 11 Nov 2008 15:53:37 DEBUG    Detected .treeinfo file
  Tue, 11 Nov 2008 15:53:37 DEBUG    Fetching URI 
  ftp://why.sjc.redhat.com/pub/ks_mirror/rhel-5-server_u1_x86_64/.treeinfo
  Tue, 11 Nov 2008 15:53:37 DEBUG    Saved file to 
  /var/lib/xen/virtinst-.treeinfo.fKzA1e
  Retrieving file .treeinfo...                                       0 B 00:00
  No section: 'general'
  Domain installation may not have been
  successful.  If it was, you can restart your domain
  by running 'virsh start it235056'; otherwise, please
  restart your installation.
  Tue, 11 Nov 2008 15:53:37 ERROR    No section: 'general'
  Traceback (most recent call last):
   File "/usr/sbin/virt-install", line 560, in ?
     main()
   File "/usr/sbin/virt-install", line 492, in main
     dom = guest.start_install(conscb, progresscb, wait=(not wait))
   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 820, 
   in start_install
     self._prepare_install(meter)
   File "/usr/lib/python2.4/site-packages/virtinst/ParaVirtGuest.py", line 56, 
   in _prepare_install
     self._installer.prepare(guest = self, meter = meter)
   File "/usr/lib/python2.4/site-packages/virtinst/DistroManager.py", line 261,
   in prepare
     self._prepare_kernel_and_initrd(guest, distro, meter)
   File "/usr/lib/python2.4/site-packages/virtinst/DistroManager.py", line 231,
   in _prepare_kernel_and_initrd
     arch = arch)
   File "/usr/lib/python2.4/site-packages/virtinst/DistroManager.py", line 133,
   in acquireKernel
     arch=arch)
   File "/usr/lib/python2.4/site-packages/virtinst/DistroManager.py", line 106,
   in _storeForDistro
     if store.isValidStore(fetcher, progresscb):
   File "/usr/lib/python2.4/site-packages/virtinst/OSDistro.py", line 125, 
   in isValidStore
     m = re.match(".*Fedora.*", self.treeinfo.get("general", "family"))
   File "/usr/lib64/python2.4/ConfigParser.py", line 511, in get
     raise NoSectionError(section)
  NoSectionError: No section: 'general'
    
Expected results:

  No errors.  Paravirt guest is installed.  Joy and happiness.
  
Additional info:

  Problem does not occur with installations using NFS or HTTP as an
  installation medium.
Comment 1 Bryan Mason 2008-11-11 19:26:46 EST
Well, this looks alot like Bug 470891 (don't know how I missed that one in my initial Bugzilla search).
Comment 2 Bryan Mason 2008-11-11 19:29:17 EST
Yup.  Verified that this is fixed in python-virtinst-0.300.2-12.el5.  Sorry for the noise.

*** This bug has been marked as a duplicate of bug 470891 ***

Note You need to log in before you can comment on or make changes to this bug.