Bug 471152 - vinagre captures keys instead of passing to the remote system
vinagre captures keys instead of passing to the remote system
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: vinagre (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 479872 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-11 20:43 EST by Noel J. Bergman
Modified: 2009-05-07 21:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 21:06:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 555803 None None None Never

  None (edit)
Description Noel J. Bergman 2008-11-11 20:43:04 EST
Description of problem:

Vinagre incorrectly captures keys, e.g., ^d, that should be going to the remote system.

Version-Release number of selected component (if applicable):

2.24.1

How reproducible:

Very.

Steps to Reproduce:
1. Connect to remote system
2. Open shell
3. Hit ^d.

Or just trying using emacs.
  
Actual results:

Vinagre pops up a dialog, captures the local keyboard such that you cannot even type in another window, and expects for you to label the bookmark.

Expected results:

The remote system should receive the keystroke.
Comment 1 Noel J. Bergman 2008-11-11 22:31:01 EST
From reading the code, I have found a workaround.  Run gconf-editor, and change apps->vinagre->show_accels to false.  That setting is described by gconf-editor as "Set to "false" to disable menu shortcuts. Set to "true" to enable them. Note that if they are enabled, those keys will be intercepted by the menu and will not be sent to the remote host."  Needless to say, having that value default to true is a very poor choice given the nature of the program.  And new users are not likely to find that hidden switch without instructions.
Comment 2 Bug Zapper 2008-11-26 00:13:45 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Gilboa Davara 2008-12-03 09:15:27 EST
FYI. Still present in F10.
Reported upstream:

http://bugzilla.gnome.org/show_bug.cgi?id=563114
Comment 4 Gilboa Davara 2008-12-03 09:17:01 EST
Just noticed the previous GNOME BZ#.
Please ignore my second report.

- Gilboa
Comment 5 Bastien Nocera 2009-05-07 20:21:33 EDT
*** Bug 479872 has been marked as a duplicate of this bug. ***
Comment 6 Bastien Nocera 2009-05-07 21:06:46 EDT
This is fixed in vinagre in F11. The work-around above will work for F10.

Note You need to log in before you can comment on or make changes to this bug.