Bug 471167 - Paths remain offline on a RHEL 5.3 host with Emulex FC adapters even after reinstating them
Paths remain offline on a RHEL 5.3 host with Emulex FC adapters even after re...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
medium Severity high
: rc
: ---
Assigned To: Tom Coughlan
Martin Jenner
: OtherQA
Depends On:
Blocks: 373081 431464
  Show dependency treegraph
 
Reported: 2008-11-11 23:59 EST by Naveen Reddy
Modified: 2009-06-20 04:06 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-12 10:17:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages with Emulex verbose enabled (321.72 KB, text/plain)
2008-11-12 00:00 EST, Naveen Reddy
no flags Details

  None (edit)
Description Naveen Reddy 2008-11-11 23:59:07 EST
Description of problem: Paths remain offline on a RHEL 5.3 host with Emulex FC adapters even after reinstating them.


Version-Release number of selected component (if applicable):
OS - RHEL5U3 GASnapshot1
kernel - 2.6.18-121.el5
device-mapper-1.02.28-2.el5
device-mapper-multipath-0.4.7-21.el5
Emulex HBA - LPe11002-M4
Emulex driver version - 8.2.0.30
Emulex firmware version - 2.80A4

How reproducible:
Always

Steps to Reproduce:
1. Map a LUN to RHEL5.3 FC host with Emulex HBA.
2. Verify that all the primary paths and secondary paths to LUN are online.
3. Make the primary paths down
4. Restore the primary paths
5. The primary paths still remain offline.
  
Actual results:
Paths are remaining offline though they are reinstated.

Expected results:
Paths should become online once the paths are reinstated.

Additional info:
Iam attaching the /var/log/messages with Emulex verbose enabled.
Comment 1 Naveen Reddy 2008-11-12 00:00:17 EST
Created attachment 323296 [details]
/var/log/messages with Emulex verbose enabled

Attaching the log messages
Comment 2 Andrius Benokraitis 2008-11-12 10:06:47 EST
Adding Emulex...
Comment 3 Andrius Benokraitis 2008-11-12 10:10:13 EST
Naveen - I know there is a newer Emulex driver in kernel-2.6.18-122.el5 which you can download here: http://people.redhat.com/dzickus/el5

* Changed version number to 8.2.0.33.2p

or just wait for the Snapshot 2 ISOs.
Comment 4 Tom Coughlan 2008-11-12 10:16:55 EST
Or even better, try a test with 5.3 with the lpfc taken from 5.2. This will help to isolate the cause.
Comment 5 laurie barry 2008-11-13 15:36:20 EST
The last driver patch that was submitted on 11/7 for RHEL5.3 inclusion is 8.2.0.33.3p. Please see Bugzilla 470610--"Update lpfc to version 8.2.0.33.3p".

We would like you to verify the issue w/ this latest 8.2.0.33.3p driver.

If this issue is reproducible with the 8.2.0.33.3p driver, could you please provide us the following information:

- How do you bring the path down and up?
- Are scsi devices going to offline state?
- Reproduce this issue with loading the lpfc driver w/ driver parameter lpfc_log_verbose=67 and send us the log file.

Thanks,
Vaios Papadimitriou
vaios@emulex.com
Comment 6 Naveen Reddy 2008-11-14 00:07:21 EST
I have tried this on latest RHLE5.3 snapshot(snapshot 2) which has lpfc driver version 8.2.0.33.2p. Paths are becoming online once they are reinstated. 

So, this issue in not reproducible with newer lpfc driver(8.2.0.33.2p).

Thank you
Naveen
Comment 7 laurie barry 2008-11-14 10:19:42 EST
Thank you Naveen.

Should we consider then this issue closed as fixed w/ the latest driver rev?

Thanks,
-Vaios-
Comment 8 Naveen Reddy 2008-11-16 23:25:43 EST
Since this issue is not seen with newer lpfc driver version, it can be closed.

Thank you 
Naveen

Note You need to log in before you can comment on or make changes to this bug.