Bug 471176 - SYSLOG(3) enhancement request
SYSLOG(3) enhancement request
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: man-pages (Show other bugs)
5.2
All Linux
medium Severity low
: rc
: ---
Assigned To: Ivana Varekova
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-12 02:38 EST by masanari iida
Modified: 2013-04-15 05:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-11 04:13:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description masanari iida 2008-11-12 02:38:47 EST
Description of problem:
syslog(3) online manual explains LOG_KERN facility level.
Current explanation "kernel messages" is not enough.

Because some other flavor of Unix syslog man page explains
this facility can be generated only by kernel.

For example,
Sun solaris,
LOG_KERN 
Messages generated by the kernel. These cannot be generated 
by any user processes.

FreeBSD,
LOG_KERN	   Messages generated by the kernel.  These cannot be gener-
		   ated by any user processes.

So, the RHEL manual need to add the limitation.

Request background.
A user tried  logger -p kern.debug "abc123" 
and he expected the logger output should route to  /var/log/kernel.log file,
which was specified by syslog.conf.

The acutual result was, the messages goes to /var/log/users
log, because the logger output has a user facility.

I know this is expected result.
But in order to answer this is expected, I need an evidence 
on the man page. The current man syslog(3) of the RHEL5 is 
not enough for my purpose.
Comment 1 masanari iida 2008-11-12 12:02:10 EST
Communicate with upstream maintainer Michael Krrisk by 
private e-mail. He wrote to me he will add one line, 
" These cannot be generated by any user processes." 
in man-pages-3.14.

> Thanks for your report and all the background.  
> I agree with you, and 
> have changed things as you suggest for man-pages-3.14.

I hope this information help.
Comment 2 Ivana Varekova 2008-11-13 03:20:44 EST
Thanks.
Comment 9 errata-xmlrpc 2009-11-11 04:13:36 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1574.html

Note You need to log in before you can comment on or make changes to this bug.