Bug 471203 - gnome-system-monitor filesystem tab crashes the application segfault
gnome-system-monitor filesystem tab crashes the application segfault
Status: CLOSED DUPLICATE of bug 456812
Product: Fedora
Classification: Fedora
Component: gnome-system-monitor (Show other bugs)
10
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
: 471930 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-12 05:57 EST by Deependra Singh Shekhawat
Modified: 2014-06-18 05:10 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 10:28:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deependra Singh Shekhawat 2008-11-12 05:57:38 EST
Description of problem:
gnome-system-monitor's filesystem tab crashes the complete application with multiple segmentation fault when run by normal user.

Version-Release number of selected component (if applicable):
kernel-2.6.27.5-94.fc10.i686
gnome-system-monitor-2.24.1-1.fc10.i386


How reproducible:
The following are the steps to reproduce the error:-

Steps to Reproduce:
1. Install a latest rawhide machine (dated 12th nov 2008)
2. Make sure the gnome-system-monitor package is as mentioned in this bug
3. Run the gnome-system-monitor as normal user and click on the filesystems tab on the top.
  
Actual results:
(gnome-system-monitor:3337): GLib-GObject-WARNING **: IA__g_object_get_valist: property `name' of object class `GThemedIcon' is not readable
terminate called after throwing an instance of 'std::logic_error'
  what():  basic_string::_S_construct NULL not valid
Multiple segmentation faults occurred; can't display error dialog


Expected results:
It should have shown the filesystems tab. Or if this feature is disabled for normal user in the rawhide the tab should be disabled/removed for normal user.

Additional info:
This can't be reproduced if gnome-system-monitor is run by root user. Any more info if needed please ask.


Thanks
Comment 1 Yanko Kaneti 2008-11-12 06:22:37 EST
bug 456812 revisited...
Comment 2 Jason Farrell 2008-11-12 12:23:00 EST
Not reproducible here, and have never encountered this bug. Using the default gnome theme/icons.
Comment 3 Ray Strode [halfline] 2008-11-17 14:27:21 EST
*** Bug 471930 has been marked as a duplicate of this bug. ***
Comment 4 Bug Zapper 2008-11-26 00:14:32 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Deependra Singh Shekhawat 2008-11-30 21:09:34 EST
Well,

I have upgraded the same machine to F10 and I don't see this happening now. Seems to be working perfectly fine.

Thanks
Comment 6 Adrian 2008-12-10 14:21:43 EST
I am experiencing a similar problem when I click on the "File Systems" tab.

[adrian@amethyst ~]$ gnome-system-monitor

(gnome-system-monitor:14824): GLib-GObject-WARNING **: IA__g_object_get_valist: property `name' of object class `GThemedIcon' is not readable
terminate called after throwing an instance of 'std::logic_error'
  what():  basic_string::_S_construct NULL not valid


[adrian@amethyst ~]$ uname -r
2.6.27.5-117.fc10.x86_64
[adrian@amethyst ~]$ rpm -q gnome-system-monitor
gnome-system-monitor-2.24.1-1.fc10.x86_64
Comment 7 NM 2008-12-18 19:23:57 EST
This happening to me too at each reboot after most recent FC10 update (x86_64). Somehow at reboot all hard disk partitions are automatically mounted to the desktop. The gnome-system-monitor "File System" tab crashes. Manually un-mounting volumes fixing the problem. Hope this would help to reproduce the bug. 
Regards, 
NM
Comment 8 Brad Lucier 2009-01-28 17:49:43 EST
Today in FC10 on ppc64 for an ordinary user account, gnome-system-monitor does not start, but the problem does not happen for root:

[lucier@descartes ~]$ gnome-system-monitor

(gnome-system-monitor:20661): GLib-GObject-WARNING **: IA__g_object_get_valist: property `name' of object class `GThemedIcon' is not readable
terminate called after throwing an instance of 'std::logic_error'
  what():  basic_string::_S_construct NULL not valid
[lucier@descartes ~]$ su -
Password: 
[root@descartes ~]# gnome-system-monitor
[root@descartes ~]# uname -r
2.6.27.12-170.2.5.fc10.ppc64
[root@descartes ~]# rpm -q gnome-system-monitor
rpmdb: Thread/process 15828/4160630784 failed: Thread died in Berkeley DB library
gnome-system-monitor-2.24.1-1.fc10.ppc
Comment 9 Jon Dufresne 2009-02-24 10:28:25 EST
This looks like a duplicate of bug 456812. That bug claims this is fixed. If the bug is in fact different than the linked to bug please feel free to reopen this bug. If the bug is the same but you are still experiencing the bug with an updated version, please reopen the linked to bug with an updated description.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 456812 ***

Note You need to log in before you can comment on or make changes to this bug.