Bug 47124 - (0.9.2-0) Arrow keys & others are broke in form entry boxes
(0.9.2-0) Arrow keys & others are broke in form entry boxes
Product: Red Hat Raw Hide
Classification: Retired
Component: mozilla (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Depends On:
  Show dependency treegraph
Reported: 2001-07-03 08:18 EDT by Mike A. Harris
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-07-13 16:11:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2001-07-03 08:18:37 EDT
Description of Problem:  With Mozilla 0.9.2-0, if you enter text into
a form text area such as this bug report form, and then press the END
key on the keyboard, the left arrow key is no longer functional until
you click the mouse elsewhere and navigate back, or do some other wicked
cursor manipulation.  Various other cursor key and HOME/END, backspace
etc related problems are present in Mozilla for some time in text entry
boxes, etc.  Also, cursor chunks ocasionally get left behind, and other
wierdities.  Those are likely fodder for another bug report sometime..

How Reproducible: 100%

Steps to Reproduce:
1. Go to any web form with a text entry box such as bugzilla
2. Enter some text, press left-arrow and it works
3. Press END key, then press left arrow, and the cursor does not move.
4) *or* hit HOME to the beginning of a line and backarrow and it does
   not move back to the previous line.

Actual Results:
Various semi-random errors with using any of the cursorkeys in mozilla
Cut and pasting text also seems to make this worse and more random.

Expected Results:
Cursor keys should all work like they do in most other applications
in both Linux, Windows and other OS's.

Additional Information:
This particular bug I believe is new to 0.9.2-0, however various
similar bugs have always been present.
Comment 1 Christopher Blizzard 2001-07-03 09:58:44 EDT
I can't reproduce this.  It's working fine here.
Comment 2 Mike A. Harris 2001-07-03 10:37:13 EDT
What can I do to try and provide more info to help track it?  I have a fresh
unmodified (packagewise) install here that I just installed Moz on and it
does it on that too.  (7.1)
I tried both 4.0.3-5, 4.0.3-21 and 4.1.0-0.7.6 with same results.  Perhaps it
is some configuration option?
Comment 3 Christopher Blizzard 2001-07-03 11:04:46 EDT
This is the kind of thing that needs to go into bugzilla.mozilla.org.  It needs
a wider audience.
Comment 4 Christopher Blizzard 2001-07-08 21:11:35 EDT
Are you using something other than one of the two default themes?

What about if you rename your .mozilla directory and let mozilla create a new
one?  Does it still show up then?  I know I've never seen this.
Comment 5 Mike A. Harris 2001-07-12 04:56:06 EDT
Sorry for the delay.  I haven't been able to test this as well as I had 
liked until just now.

For your first comment, ok no prob, I'll try to file bugs in mozilla's
own bugzilla unless I think they are specific to us from now on.  Good idea.

Second comment:  No, I was using the "modern" theme that comes with Mozilla.
I do not add that kind of stuff to my local setup, I'm a meat and potatoes
guy mostly WRT eye candy.  ;o)  I tried the other classic theme too and it
didn't change anything.

I just moved my .mozilla dir to elsewhere and started over from scratch.
After starting mozilla for the first time I left all defaults, and just
went into bugzilla, logged in and tried to update a bug report.  I still
get the arrow key problem.  Did the same on another box - fresh install
of seawolf with no updates, fresh mozilla run,same bug.  I dunno how
it doesn't happen for anyone else if it doesn't.  This is using the 0.9.2-0
RPM's as mentioned above.  If you can't reproduce it this is really scary
because my fresh install was on a blank disk and I just config'd X (Radeon 64)
upgraded Mozilla to above, and started up KDE,and ran mozilla.  It might
not be a Mozilla bug, but it's sure got me what it would be if it isn't..

Can you try reproducing on a fresh install?  Or should I submit it to Mozilla
instead and let someone else try to reproduce?  I know it is a nasty one to
try to figure out so if you'd rather pass the buck upstream it's ok with me.
;o)  I do that all the time.  ;o)  Lemme know what I should do next, and I'll
do it.
 Thanks Chris.
Comment 6 Mike A. Harris 2001-07-12 05:13:06 EDT
Oooh!  Another update!  ;o)  I just went to do another bug report update and
discovered this semi-random but not behaviour.  Ok, I entered 3 lines of
text similar to where I am right now in this report.

After the three lines I went up and fixed a spelling error, then came back
down to the last line I was editing.  I then hit END, and back arrow and it
worked!  Then I played around a bit.  On the last line of the message with
no blank lines below, I hit END, leftarrow, works.  END right-arrow, left
arrow, doesn't work.  END, down arrow leftarrow (doesn't do anything, but
triggers the behaviour), doesn't move to the left.

Now while typing the above, I had the behaviour) part as the end of the line,
and cursored up to go fix a spelling mistake in the word arrow at the point
"down arrow", I hit up arrow at the ) point, and then right arrowed to get
to the first r in arrow, but when I got to the word END, the cursor would
not move anymore.  I had to hit uparrow to the "h" in hit above the word END,
then right arrow over to where I wanted, and then down arrow.  After that,
right and left arrow work fine.

I can very easily reproduce tonnes of cursor key related bugs in this form
entry box.  I wish Mozilla had a debug mode to show a separate window with
all the cursor coordinates in it that might help track this down.
New bug.  ;o)  On the word down. at the end of the sentence above, while
typing it, I hit uparrow, leftarrow, leftarrow, downarrow, downarrow, "."
What happened was it went up, left, left, down, then the second downarrow
moved the cursor to the end of the line as if I pressed END, then the
cursor was right after the word "down" and I pressed ".", and instead 
of putting "." there, it moved to the next line and put a ".", it definitely
wasn't an intentional wordwrap thing either.  I tried it again just a second
ago with the cursor in the 10th column and it does it repeatably.

Sorry to go on and on about this, just trying to provide useful datapoints
with which to reproduce all this flaky behaviour.  Now I'm going to
see if anyone on testers-list can reproduce also.  Thanks, TTYL
Comment 7 Enrico Scholz 2001-07-12 05:57:47 EDT
I am seeing similar effects with galeon after pasting text with the mouse. E.g.
when I mark the last two lines of your comment and paste them into this
comment-box, I can not go left at the end of the line. Don't know if this is the
same issue...
Comment 8 Christopher Blizzard 2001-07-12 14:42:44 EDT
Opened as:

Comment 9 Christopher Blizzard 2001-07-12 23:24:21 EDT
I'm pretty sure this has been fixed in the 0.9.2-6 rpms.  Give them a spin.
Comment 10 Mike A. Harris 2001-07-13 16:11:16 EDT
The END, leftarrow appears fixed, but there are many numerous bugs left,
which are easy to reproduce by just using common cursor key strokes and
seeing odd behaviour.  I will report them upstream instead though.

This bug should be left open though until they're fixed.
Comment 11 Christopher Blizzard 2002-01-25 15:58:33 EST
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.