This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 471264 - python-bugzilla always fails with ProtocolError: 500 Internal Server Error
python-bugzilla always fails with ProtocolError: 500 Internal Server Error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-bugzilla (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-12 12:56 EST by Jason Farrell
Modified: 2009-04-14 11:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 11:51:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Farrell 2008-11-12 12:56:08 EST
After learning of the 'bugzilla' CLI utility from Jon Stanley, in https://fedoraproject.org/wiki/Classroom/Bugzilla_Intro, I've been very eager to use it to avoid the insane browser-based javascript annoyance, but, I've yet to actually see it work. May just be a long-standing server-side issue.

Versions affected:
python-bugzilla-0.3-1.fc9.noarch
python-bugzilla-0.4-0.rc4.fc10.noarch

e.g.:
[root@nano gconf]# bugzilla --verbose --debug --user farrellj@gmail.com --password MYPASSHERE query "python-bugzilla"
INFO:bugzilla:Connecting to https://bugzilla.redhat.com/xmlrpc.cgi
INFO:bugzilla:Using username/password for authentication
DEBUG:bugzilla:bz.query: {'bug_status': ['NEW', 'VERIFIED', 'ASSIGNED', 'NEEDINFO', 'ON_DEV', 'FAILS_QA', 'REOPENED']}
Traceback (most recent call last):
  File "/usr/bin/bugzilla", line 227, in <module>
    buglist = bz.query(q)
  File "/usr/lib/python2.5/site-packages/bugzilla.py", line 351, in query
    r = self._query(query)
  File "/usr/lib/python2.5/site-packages/bugzilla.py", line 324, in _query
    return self._proxy.bugzilla.runQuery(query,self.user,self.password)
  File "/usr/lib64/python2.5/xmlrpclib.py", line 1150, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.5/xmlrpclib.py", line 1440, in __request
    verbose=self.__verbose
  File "/usr/lib/python2.5/site-packages/bugzilla.py", line 703, in request
    headers
xmlrpclib.ProtocolError: <ProtocolError for bugzilla.redhat.com/xmlrpc.cgi: 500 Internal Server Error>
Comment 1 Bug Zapper 2008-11-26 00:15:46 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Jon Stanley 2008-12-07 14:56:56 EST
This is the right way to use components.  Unfortuantely, the -c logic is broken in the current packaged version (0.4.0-rc4), however, it's fixed in upstream git at git://git.fedorahosted.org/python-bugzilla.git

[jstanley@bigbrother bin]$ ./bugzilla --user=jonstanley@gmail.com query -p Fedora -c python-bugzilla -t NEW,ASSIGNED
Password: 
#470701 NEW        - wwoods@redhat.com - bugzilla command > query subcommand > '-c/--component' option does not act as documented in man page
#471264 NEW        - wwoods@redhat.com - python-bugzilla always fails with ProtocolError: 500 Internal Server Error
#456518 NEW        - wwoods@redhat.com - multicall fails with getbugssimple
Comment 3 Jon Stanley 2009-02-11 22:55:36 EST
This has been fixed awhile, no?  I don't think there's been a new release since 0.4.0-rc4 though that I can see.

Will - could we get a new release to fix the -c behavior that we found out about awhile back (and whatever new hotness you have in store)
Comment 4 Will Woods 2009-04-14 11:51:23 EDT
This should all be fixed as of 0.5 - note that python-bugzilla 0.5.1-1 is broken, but -2 fixes that.

Note You need to log in before you can comment on or make changes to this bug.