Bug 471311 - Support for ttl and message expiration [RHEL4]
Support for ttl and message expiration [RHEL4]
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.0
All Linux
urgent Severity medium
: ---
: ---
Assigned To: messaging-bugs
Kim van der Riet
:
Depends On: 453536
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-12 16:44 EST by Justin Ross
Modified: 2009-02-04 11:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 11:16:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Ross 2008-11-12 16:44:06 EST
+++ This bug was initially created as a clone of Bug #453536 +++

If a ttl is set messages should be expired from queues after the desired time.

See https://issues.apache.org/jira/browse/QPID-528

--- Additional comment from gsim@redhat.com on 2008-10-02 11:08:05 EDT ---

*** Bug 448589 has been marked as a duplicate of this bug. ***

--- Additional comment from gsim@redhat.com on 2008-10-14 07:22:03 EDT ---

Committed final part of this (for now at least!) in r704461. Tests exist in c++ and python (cpp/src/tests/ClientSessionTest::testExpirationOnPop and cpp/src/tests/ClientSessionTest::testPeriodicExpiration and python/tests_0-10/message/test_ttl).

Messages are checked for expiry before dispatching them to subscribers. Epired messages are dropped on dequeue and periodically all expired messages are expunged  unless the rate of dequeues since last purge is higher than one per second). The rate of the periodic purging of expired messages can be configured via the --queue-clean-interval option to qpidd.
Comment 2 Frantisek Reznicek 2009-01-06 12:20:37 EST
C++ tests mentioned above exists and passing on RHEL 4.7 i386/x86_64.
Feature implemented.
->VERIFIED
Comment 4 errata-xmlrpc 2009-02-04 11:16:28 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0038.html

Note You need to log in before you can comment on or make changes to this bug.