Bug 471327 - ssh shows last login details regardless of .hushlogin file
ssh shows last login details regardless of .hushlogin file
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openssh (Show other bugs)
4.7
All Linux
medium Severity low
: rc
: ---
Assigned To: Tomas Mraz
BaseOS QE
https://bugzilla.mindrot.org/show_bug...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-12 18:47 EST by John Newbigin
Modified: 2008-11-13 08:01 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-13 08:01:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Newbigin 2008-11-12 18:47:30 EST
Description of problem:
When a user has a .hushlogin file in their home directory, the MOTD and last login should not be displayed at login.

sshd does not show the MOTD but it still shows the last login


Version-Release number of selected component (if applicable):
openssh-server-3.9p1-8.RHEL4.24


How reproducible:
Every time


Steps to Reproduce:
1.
2.
3.
  
Actual results:
ssh user@localhost
user@localhost's password:
Last login: Thu Nov 13 10:20:48 2008 from localhost.localdomain
This is the MOTD

[user@localhost ~]$ ls .hushlogin
ls: .hushlogin: No such file or directory
[user@localhost ~]$ touch .hushlogin
[user@localhost ~]$ exit

ssh user@localhost
user@localhost's password:
Last login: Thu Nov 13 10:43:37 2008 from localhost.localdomain
[jnewbigin@ictvansvr1 ~]$


Expected results:
ssh user@localhost
user@localhost's password:
[jnewbigin@ictvansvr1 ~]$


Additional info:
Looks like a known bug in ssh
https://bugzilla.mindrot.org/show_bug.cgi?id=927
Comment 1 Tomas Mraz 2008-11-13 08:01:00 EST
Given the state of maintenance of Red Hat Enterprise Linux 4 we will not backport this functionality to this version.

This feature is implemented in the Red Hat Enterprise Linux 5 openssh package.

Note You need to log in before you can comment on or make changes to this bug.