Bug 471333 - ATI (radeon) driver doesn't fails on my ATI HD 3200 (RS780M/RS780MN)
ATI (radeon) driver doesn't fails on my ATI HD 3200 (RS780M/RS780MN)
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-11-12 19:37 EST by Andrig Miller
Modified: 2009-10-10 04:07 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-09-07 02:53:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Xorg log file (100.96 KB, text/plain)
2008-11-12 22:26 EST, Andrig Miller
no flags Details

  None (edit)
Description Andrig Miller 2008-11-12 19:37:46 EST
Description of problem:

The radeon driver fails to enable hardware acceleration of any kind (2D or 3D).

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Start up X.
Actual results:

The Xorg.0.log shows a failure to initialize hardware acceleration for both 2D and 3D, and the radeon module is not loaded.  It falls back to the frame buffer driver (or that's what I think it does).

Expected results:

I have seen conflicting information on whether my particular graphics chip has 2D or 3D support (I read an article that was dating back to May that said that the ati (radeon) driver, which uses AtomBios did support this), so this may not be a bug, but just require a newer release of the driver, I'm not really sure.

So, what I expect is at least 2D hardware acceleration, and the radeon driver to load.

Additional info:

I have attached my Xorg.0.log that shows the autoconfiguration, and the errors that come out from the radeon driver.
Comment 1 Matěj Cepl 2008-11-12 21:35:25 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Andrig Miller 2008-11-12 22:26:10 EST
Created attachment 323419 [details]
Xorg log file

Here is my Xorg.0.log file, and there is no xorg.conf file.  This is a pristine Fedora 10 preview install on a new laptop.  You will see the auto-configuration in the Xorg.0.log file that is attached.
Comment 3 Bug Zapper 2008-11-26 00:16:45 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
Comment 4 Vedran Miletić 2009-09-06 02:45:18 EDT
Reporter, please retest with Fedora 11 or Fedora 12 Snap1 (from http://torrent.fedoraproject.org/). There is a great chance that this is already fixed.
Comment 5 Andrig T Miller 2009-09-06 22:01:18 EDT
I have been running Fedora 11, and it has 2D acceleration, but there is still no 3D acceleration, but I have been following the commits and I know that is still in development, although there is some 3D support from what I see in the commits, there hasn't been a release in a long time, so I'm not sure if that works.

Basically, this can be closed.
Comment 6 Vedran Miletić 2009-09-07 02:53:33 EDT
Thanks for responding.

3D will probably arrive with Mesa 7.6, which will hopefully be ready in time for Fedora 12. Fingers crossed.
Comment 7 Richard Schwarting 2009-10-09 20:11:08 EDT
Apparently it didn't make it.  (Saying that from F12Alpha).  Mesa 7.6 is here, but no KMS on boot, no 3D acceleration.
Comment 8 Vedran Miletić 2009-10-10 03:31:26 EDT
Try a newer snapshot, from here: http://alt.fedoraproject.org/pub/alt/nightly-composes/
Comment 9 Richard Schwarting 2009-10-10 04:07:24 EDT
Hmm.  I had tried installing the mesa-dri-drivers-experimental package for its r600 support, but restarting X didn't seem to benefit from its installation, and the only thing persistent about my persistent overlay seems to be /home/**. 

I'm trying the compose listed 20091009, but I'm under the impression that I'll still need to try to use r600_dri.so provided by mesa-dri-drivers-experimental for the RS780M/RS780MN.

Note You need to log in before you can comment on or make changes to this bug.