Bug 471345 - "better" boot configuration doesn't allow choosing a kernel over serial console
"better" boot configuration doesn't allow choosing a kernel over serial console
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
10
All Linux
high Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-12 23:14 EST by Chris Snook
Modified: 2009-05-04 10:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 10:48:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Snook 2008-11-12 23:14:21 EST
Description of problem:
The "better" boot configuration doesn't properly handle the serial console case.  If connecting via serial console, it's impossible to change which kernel boots, making recovery impossible if a kernel update goes bad.

Version-Release number of selected component (if applicable):
grub-0.97-36.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install a system (or KVM guest) with console=ttyS0 at the boot prompt.
2. Boot the system, connecting via the serial console.
3. Hold down a key to enter the grub menu.

Actual results:
Anaconda automatically configures grub to display via the serial console, but it's impossible to enter the grub menu via the serial console.

Expected results:
Some mechanism to enter the grub menu via serial console.

Additional info:
Using "timeout=5" allows grub to be accessed over serial.

Since Anaconda already has logic to automatically configure grub.conf to display via a serial console when the installer is booted with console=ttyS0, it should be trivial to augment that logic to insert the old style timeout configuration as well when a serial console is used for grub.
Comment 1 Jeremy Katz 2008-11-13 10:36:47 EST
What version of booty was in the tree you installed with?  booty-0.105-1 should include a fix for this (changing the timeout if we set up a serial console)
Comment 2 Chris Snook 2008-11-13 12:24:37 EST
I installed from the F10 Preview ISO, which appears to have that version of booty.  It's setting up chaintimeout=5, but that doesn't help since the system isn't configured to chainload.
Comment 3 Bug Zapper 2008-11-26 00:17:06 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Jeremy Katz 2009-05-04 10:48:01 EDT
We changed this around before Fedora 10 and it should be acting a lot more like you'd expect now

Note You need to log in before you can comment on or make changes to this bug.