Bug 471374 - Does not work when glxinfo returns "error"
Does not work when glxinfo returns "error"
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: opengl-games-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 05:49 EST by Mamoru TASAKA
Modified: 2008-11-13 10:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-13 09:44:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2008-11-13 05:49:52 EST
Description of problem:
On my system, unfortunately with xorg-x11-drv-i810-2.5.0-3.fc10
(I noticed that) glxinfo returns:
------------------------------------------------------------
$ glxinfo
name of display: :3.0
[intel_init_bufmgr:495] Error initializing buffer manager.
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Serial number of failed request:  25
  Current serial number in output stream:  28
------------------------------------------------------------

In this case
------------------------------------------------------------
$ glxinfo 2>/dev/null
name of display: :3.0
------------------------------------------------------------

So in opengl-game-functions.sh (in opengl-games-utils),
$(glxinfo | grep "direct rendering: " | head -n 1 | cut -d " " -f 3) is empty
and

[tasaka1@localhost ~]$ ln -sf /usr/bin/opengl-game-wrapper.sh glxinfo-wrapper
[tasaka1@localhost ~]$ ./glxinfo-wrapper 
[intel_init_bufmgr:495] Error initializing buffer manager.
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Serial number of failed request:  25
  Current serial number in output stream:  28
/usr/share/opengl-games-utils/opengl-game-functions.sh: line 4: [: !=: unary operator expected
name of display: :3.0
[intel_init_bufmgr:495] Error initializing buffer manager.
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Serial number of failed request:  25
  Current serial number in output stream:  28

So actually "checkDriOK $GAME" (in opengl-game-wrapper.sh) _succeeds_,
which caused freeze when executing stellarium-wrapper (in stellarium).
In this case opengl-game-wrapper.sh (stellarium-wrapper)
should exit abnormally before stellarium is called.

Version-Release number of selected component (if applicable):
opengl-games-utils-0.1-5.fc9.noarch

How reproducible:
100%

Steps to Reproduce:
1. see above
2.
3.
Comment 1 Hans de Goede 2008-11-13 09:44:01 EST
Thanks for reporting this, here is a new version which you can try which fixes this:
http://koji.fedoraproject.org/koji/taskinfo?taskID=931241

However the real issue here is that the intel driver / intel kernel drm is screwing up badly, I hope you've filed a bug for this?

Given that this only papers over the real bug and were frozen this fix will not be included in to F-10.
Comment 2 Mamoru TASAKA 2008-11-13 10:41:59 EST
(In reply to comment #1)
> However the real issue here is that the intel driver / intel kernel drm is
> screwing up badly, I hope you've filed a bug for this?

Umm.. Actually I have _multiple_ (really multiple) issues with
X server/intel driver/mesa/kernel currently, unfortunately.... very bad. 
And confusingly, there are some examples that while I upgrade one 
component a problem seems to be fixed but another problem happens...

So indeed I filed some issues which seems more serious to me, however I no longer
cannot find out against what component I should file bugs....

Note You need to log in before you can comment on or make changes to this bug.