Bug 471386 - system-config-display produces vesa config that's incompatible with monitor
system-config-display produces vesa config that's incompatible with monitor
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vesa (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 08:19 EST by Jonathan Kamens
Modified: 2009-06-29 11:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 11:44:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf, system-config-display, openchrome changed to vesa, geometry changed to 1400x1050 (617 bytes, text/plain)
2008-11-13 23:05 EST, Jonathan Kamens
no flags Details
Xorg.1.log from "xinit -- :1" with attached xorg.conf file (103.52 KB, text/plain)
2008-11-13 23:07 EST, Jonathan Kamens
no flags Details

  None (edit)
Description Jonathan Kamens 2008-11-13 08:19:30 EST
I have an openchrome video card and a ViewSonic flatscreen monitor.  I've had problems with the openchrome driver, so I usually use vesa instead.  This morning I ran system-config-display.  It autodetected the type of the viewsonic monitor and the openchrome card, but I then changed the driver from openchrome to vesa and saved the config.  When I tried to start X, my monitor claimed that the refresh frequency was out of range and wouldn't display anything.  It seems that, at least for some monitors, system-config-display needs to tell the server which mode lines are supported, or at least to specify the maximum and minimum refresh rates for the monitor (which weren't specified in the xorg.conf generated by system-config-display).
Comment 1 Matěj Cepl 2008-11-13 16:27:24 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Jonathan Kamens 2008-11-13 23:05:55 EST
Created attachment 323528 [details]
xorg.conf, system-config-display, openchrome changed to vesa, geometry changed to 1400x1050

I see in this xorg.conf file that there's nothing indicating that I told it to use 1400x1050 as the geometry.  I wonder if this is the problem -- perhaps system-config-display isn't saving this setting properly.
Comment 3 Jonathan Kamens 2008-11-13 23:07:26 EST
Created attachment 323529 [details]
Xorg.1.log from "xinit -- :1" with attached xorg.conf file

There's no point in attaching the output of running the Xorg server when there's no Xorg.conf file, since (a) the problem here is with system-config-display, not the X server, (b) when I run with no xorg.conf, it uses the openchrome driver, when the problem I'm reporting is with the vesa driver, and (c) in any case the openchrome driver doesn't work on my machine because of all the other issues about it reported in other defects, so it's not a good control case.
Comment 4 Matěj Cepl 2008-11-14 16:25:57 EST
(In reply to comment #3)
> There's no point in attaching the output of running the Xorg server when
> there's no Xorg.conf file

Yes, you are right -- there are just too many Rawhide bugs I suppose :(

Sorry, about it.
Comment 5 Bug Zapper 2008-11-26 00:18:26 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Adam Jackson 2009-02-08 15:59:07 EST
It's not clear what version of the vesa driver this is reported against, but I suspect it's fixed as of version 2.0 or so.  Reporter, are you still seeing this problem?

Moving to vesa component, s-c-d is generating the expected thing here, the vesa driver's just mishandling it.
Comment 7 Jonathan Kamens 2009-02-10 17:49:43 EST
This problem no longer occurs in current rawhide.
Comment 8 Adam Jackson 2009-06-29 11:44:39 EDT
Closing as per comment #7.

Note You need to log in before you can comment on or make changes to this bug.