Bug 471417 - PackageKit 'offline' message is misleading
PackageKit 'offline' message is misleading
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
10
All Linux
medium Severity low
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 457972 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 11:39 EST by Bernard Johnson
Modified: 2008-12-09 09:33 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-08 16:25:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernard Johnson 2008-11-13 11:39:06 EST
Description of problem:
PackageKit tells me that it can't install a package because I'm offline.  My understanding is that it's querying NetworkManager and NetworkManager is not managing my connection.  I am not offline.

Version-Release number of selected component (if applicable):
PackageKit-0.3.9-4.fc10.i386

How reproducible:
Always

Expected results:
A sensible message that helps to resolve the problem at hand.
Comment 1 Charles R. Anderson 2008-11-13 17:16:44 EST
*** Bug 457972 has been marked as a duplicate of this bug. ***
Comment 2 Bug Zapper 2008-11-26 00:19:06 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Richard Hughes 2008-12-08 03:27:50 EST
Do you have Networkmanager running? Please see the options in /etc/PackageKit/PackageKit.conf if this is the case.
Comment 4 Bernard Johnson 2008-12-08 10:54:40 EST
Hmm... I didn't even know that option was there.  No, NetworkManager was not running - I ended up uninstalling NetworkManager instead.

Isn't there something more automatic that can be done here?

Short of that, maybe the message should indicate that this could be configuration problem and where to look?
Comment 5 Bernard Johnson 2008-12-08 13:28:32 EST
(In reply to comment #4)
> No, NetworkManager was not
> running - I ended up uninstalling NetworkManager instead.
> 

Let me correct myself a bit - NM was installed and running, but not managing any interface.
Comment 6 Richard Hughes 2008-12-08 16:25:06 EST
NetworkManager is the way to get the network state. If you're not using a "just works" interface, then you will have to edit the config file. We already use a fallback heuristic, and if that doesn't work, you're on your own.
Comment 7 Bernard Johnson 2008-12-08 17:18:09 EST
I think you missed the point.  The message that you are 'offline' is absolutely incorrect.  I'm just asking for a better message.

Even something like 'you're either offline or not using NetworkManager so your interface state can not be determined' would be better.

The current message doesn't even begin to describe the real problem or offer helpful advice.
Comment 8 Richard Hughes 2008-12-09 09:33:42 EST
Would a new user know what "interface state can not be determined" means? We also kow the state of the interface, it's just not being managed by NetworkManager.

The current logic is:

if (NetworkManager is alive)
  ask if we are connected
else
  use a unix fallback detection

So if you are running NetworkManager, but not using it, then it's going to report offline. You can either turn off NetworkManager or use it, it's up to you.

Note You need to log in before you can comment on or make changes to this bug.