Bug 471435 - [enh] Support tri-state rfkill with 2.6.27 rfkill enhancements
[enh] Support tri-state rfkill with 2.6.27 rfkill enhancements
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
10
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 449891 469558 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 13:00 EST by Lebenskuenstler
Modified: 2009-09-09 11:00 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-09 11:00:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lebenskuenstler 2008-11-13 13:00:51 EST
Description of problem:

If I switch my WLAN device [lspci: 07:03.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5788 Gigabit Ethernet (rev 03)] with the button for turning off my WLAN (HP 2133), the wireless hardware will be deactivated. Also Bluetooth gets disabled as it should. 
While the BT-icon in the GNOME bar disappears, the NM thinks he just lost his connection to his networks and tries to reconnect which. After some time of trying he prompts for reentering the password. If you click abort, NM will stay quite.
If you switch the WLAN hardware on again, NM also does not recohnize this. You have to click to the desired WLAN manually.


Version-Release number of selected component (if applicable):

kernel 2.6.27.5-94, module b43 with firmware http://mirror2.openwrt.org/sources/broadcom-wl-4.150.10.5.tar.bz2
NM 0.7.0
Comment 1 Dan Williams 2008-11-13 16:50:47 EST
This is a HAL bug; if the HAL killswitch callout recognizes that the wireless is disabled, so will NetworkManager.
Comment 2 Dan Williams 2008-11-17 14:04:22 EST
*** Bug 449891 has been marked as a duplicate of this bug. ***
Comment 3 Dan Williams 2008-11-17 14:04:34 EST
*** Bug 469558 has been marked as a duplicate of this bug. ***
Comment 4 Dan Williams 2008-11-17 14:06:35 EST
Lets make this the rfkill bug.

Basically, HAL needs to:

1) Nicely handle new 2.6.27 generic rfkill devices
2) Handle all 3 rfkill states (hardblock, softblock, unblocked)
3) Listen for and respond to uevents for rfkill state changes

Then NM can actually disable wireless.
Comment 5 Bug Zapper 2008-11-26 00:19:51 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Donald Cohen 2009-03-06 18:39:00 EST
I can't tell whether this is the same problem I'm having.
I find that I can turn off the wireless by pressing on the button, but then I cannot turn it back on by pressing the button again.  If there's another way to turn it back on I'd like to know what it is!
Also tell me whether this is the same bug or another bug that has been reported, or a new one to be reported.
Comment 7 Hedayat Vatankhah 2009-03-07 07:02:30 EST
As a workaround, you can disable Wireless networks by right clicking on NM, and enable it again!!
Comment 8 Donald Cohen 2009-03-07 13:48:35 EST
(In reply to comment #7)
> As a workaround, you can disable Wireless networks by right clicking on NM, and
> enable it again!!  

My problem is that I occasionally touch the kill switch accidentally!
Comment 9 Scott Glaser 2009-09-09 08:20:18 EDT
Have you tried with the latest hal package in Fedora 10, Fedora 11 or tried Rawhide? In either case, can you let us know whether the issue is still happening, and give the current version of the HAL packages you're using?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Donald Cohen 2009-09-09 10:39:05 EDT
hal-devel-0.5.12-29.20090226git.fc11.x86_64
hal-0.5.12-29.20090226git.fc11.x86_64
I was able to turn it back on - so this is now working for me.
Thanks!
Comment 11 Scott Glaser 2009-09-09 11:00:18 EDT
Based on the information provided in comment 10 I am closing this bug.  Should you again experience the symptoms of this bug, please file a new bug against the applicable component.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.