Bug 47144 - fonts and maps required by anaconda are missed
fonts and maps required by anaconda are missed
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kbd (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-03 11:24 EDT by Leonid Kanter
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-03 14:02:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed update (6.25 KB, application/octet-stream)
2001-07-03 13:38 EDT, Leonid Kanter
no flags Details
proposed change to spec file (462 bytes, patch)
2001-07-03 13:44 EDT, Leonid Kanter
no flags Details | Diff

  None (edit)
Description Leonid Kanter 2001-07-03 11:24:17 EDT
Description of Problem:

unable to set cyrillic fonts

How Reproducible:

always

Steps to Reproduce:

1. create following /etc/sysconfig/i18n
(created by anaconda if Russian selected)

LANG="ru_RU.koi8r"
SUPPORTED="ru_RU.koi8r:ru_RU:ru"
SYSFONT="cyr-sun16"
SYSFONTACM="koi8-r"

2. reboot

Actual Results:

You'll see box drawing characters in place of cyrillic characters during boot

Expected Results:

There must be cyrillic characters, and they were with consoletools.

Additional Information:
	
font cyr-sun16, listed in anaconda's lang-table for Russian, Serbian and
Ukrainian, and screen maps koi8-r and koi8-u, are missed from kbd package.
Please take them from consoletools and include.
Comment 1 Bernhard Rosenkraenzer 2001-07-03 11:33:51 EDT
Actually they were renamed, not removed. Anaconda needs to create a new-style 
/etc/sysconfig/i18n.



*** This bug has been marked as a duplicate of 46209 ***
Comment 2 Leonid Kanter 2001-07-03 12:17:26 EDT
I got the idea. It must be CHARSET=koi8-r or CHARSET=KOI8-R in
/etc/sysconfig/i18n. But required files are still missed. See what happens:

[root@t440 consoletrans]# mapscrn 8859-5
[root@t440 consoletrans]#
(OK)
But:
[root@t440 consoletrans]# mapscrn KOI8-R
mapscrn: cannot open map file _KOI8-R_
Or:
[root@t440 consoletrans]# mapscrn koi8-r
mapscrn: cannot open map file _koi8-r_

I can create and provide required files koi8-r_to_uni.trans,
koi8-u_to_uni.trans, cp1251_to_uni.trans.

In addition, I see no suitable replacement for cyr-sun16 font. It's the only
font containing all necessary for koi8-{r,u}/iso8859-5/cp1251 cyrillic
characters. If it was renamed, what's new name?

Comment 3 Bernhard Rosenkraenzer 2001-07-03 12:27:13 EDT
I don't speak russian, but in theory

mapscrn /lib/kbd/unimaps/koi8r.uni

should work, and the fonts
cyr_a8x14.psfu.gz
cyr_a8x16.psfu.gz
cyr_a8x8.psfu.gz
latarcyrheb-08.psfu.gz
latarcyrheb-14.psfu.gz
latarcyrheb-16.psfu.gz
latarcyrheb-16+.psfu.gz
latarcyrheb-19.psfu.gz

should be complete. Can you check this, please?
Comment 4 Leonid Kanter 2001-07-03 13:04:32 EDT
> mapscrn /lib/kbd/unimaps/koi8r.uni

yes, it works but it's difficult to call it from initscripts.

> cyr_a8x14.psfu.gz
> cyr_a8x16.psfu.gz
> cyr_a8x8.psfu.gz

All Ukrainian characters are missed.May not be used for uk_UA.

> latarcyrheb-08.psfu.gz
> latarcyrheb-14.psfu.gz
> latarcyrheb-16.psfu.gz
> latarcyrheb-16+.psfu.gz
> latarcyrheb-19.psfu.gz

Most characters are present, but 

<U0491>     /xad         CYRILLIC SMALL LETTER GHE WITH UPTURN
<U0490>     /xbd         CYRILLIC CAPITAL LETTER GHE WITH UPTURN

are absent. May not be used for uk_UA too.

Comment 5 Leonid Kanter 2001-07-03 13:38:19 EDT
Created attachment 22607 [details]
proposed update
Comment 6 Leonid Kanter 2001-07-03 13:44:03 EDT
Created attachment 22608 [details]
proposed change to spec file
Comment 7 Leonid Kanter 2001-07-03 14:02:34 EDT
I rebuild package and verified that it works OK for Russian and Ukrainian locales.

LANG="ru_RU.koi8r"
SYSFONT="cyr-sun16"
CHARSET="koi8-r"
(Russian)

LANG="uk_UA"
SYSFONT="cyr-sun16"
CHARSET="koi8-u"
(Ukrainian)
So minimal change to anaconda required and no changes at all to initscripts.
Comment 8 Bernhard Rosenkraenzer 2001-07-03 16:05:45 EDT
Thanks, added in 1.06-4

Note You need to log in before you can comment on or make changes to this bug.