Bug 471467 - Modules loaded don't enable in console anymore
Modules loaded don't enable in console anymore
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf (Show other bugs)
1.1
All Linux
medium Severity high
: 1.1
: ---
Assigned To: Ernie
Jeff Needle
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 16:00 EST by Carl Trieloff
Modified: 2011-08-12 12:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 10:37:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl Trieloff 2008-11-13 16:00:05 EST
If I load the store module, it shows up in qpid-tool by it does not enable in the console.

I 'think' the issue has come in since the namespace rename

Carl.
Comment 1 Ernie 2008-12-08 12:15:38 EST
Problem in capitalization in classToSchemaNameMap and schemaToClassNameMap
Comment 3 Jan Sarenik 2008-12-11 09:06:45 EST
I would like to verify this bug, but I do not understand how can I
reproduce it or prove it got fixed. Please provide me with more
info. Thanks.
Comment 4 Jeff Needle 2008-12-11 10:21:49 EST
Moving back to ON_QA because bug us fixed but still needs to be verified.  Leaving the NEEDINFO flag set to indicate that QE needs more information to test.
Comment 5 Ernie 2008-12-11 11:24:11 EST
To test:
- Update to cumin r2958
- In Cumin, register a broker that has either the acl or cluster module loaded. Currently jross.usersys.redhat.com has the acl module running.
- Click the Messaging tab at the top of the page
- Click on the broker in the broker list
- You'll see the broker tabs (Queues, Exchanges, Connections, etc.)
- Click on the Access Control or Clustering tab, depending on which module is running on the broker.
- You should see a Properties/Statistics page if cumin detected the module. You'll see "This module is not enabled" if cumin didn't detect the module.
Comment 6 Jan Sarenik 2008-12-15 05:16:43 EST
The bug is still there in version cumin-0.1.2997-1.el5

I have reproduced it this way (starting with clear cumin database):

  1. install qpidd-acl module

  2. create a dummy acl file in /root/.qpidd/qpidd.acl:

        acl allow all all

  3. run qpidd

        qpidd --auth yes --mgmt-enable yes --log-enable info+ \
            --acl-file qpid.acl

     * now I can see in the log that ACL module gets loaded

  4. run qpid-tool and on its shell, the command 'schema'
     * this way I double-checked that ACL module is loaded

  5. log in to Cumin MRG Management, add a 'local' broker at '127.0.0.1'

  6. click on Access Control tab where I find
     * "This module is not enabled"
Comment 7 Justin Ross 2008-12-15 14:46:26 EST
This is fixed in revision 3002.  Just had to manually update the schema now that the upstream xml schemas have changed.  I've verified that modules are working for me.
Comment 8 Jan Sarenik 2008-12-16 09:35:39 EST
Yes, the ACL module works well in revision 3002. I have not tested
with cluster module because I am still not familiar with running
qpidd in cluster mode.
Comment 10 errata-xmlrpc 2009-02-04 10:37:20 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0035.html

Note You need to log in before you can comment on or make changes to this bug.