Bug 471488 - Wireless becomes unusable - SELinux preventing read
Wireless becomes unusable - SELinux preventing read
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 17:33 EST by Kevin Tough
Modified: 2014-03-16 23:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 10:30:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error message from SELinux (2.93 KB, text/plain)
2008-11-13 17:33 EST, Kevin Tough
no flags Details
/var/log/messages text (4.27 KB, application/octet-stream)
2008-11-13 17:58 EST, Kevin Tough
no flags Details

  None (edit)
Description Kevin Tough 2008-11-13 17:33:27 EST
Created attachment 323505 [details]
Error message from SELinux

Description of problem: Wireless card will not connect because of SELinux.


Version-Release number of selected component (if applicable):


How reproducible: Install software for wireless and allow it to connect. After about 1 hour connection will be terminated. Upon rebooting card may connect temporarily. Within days rebooting will also not function.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2008-11-13 17:38:22 EST
Can you do a full relabel?

There's no reason that consoletype should be ever reading that file.
Comment 2 Kevin Tough 2008-11-13 17:58:11 EST
Created attachment 323507 [details]
/var/log/messages text

I hope this describes the problem.
Comment 3 Kevin Tough 2008-11-17 00:56:50 EST
After updating to the new kernel the problem seems to have vanished????

I still have error messages when booting about bit rate and sometimes that the IP address for the wlan0 was not determined but once logged in the wlan0 is active and remains so.

My thanks to whomever. If anyone wishes to still work on this bug then please send me info about whatever additional info you need.

Namaste,

Kevin Tough
Comment 4 Kevin Tough 2008-11-17 00:57:35 EST
(In reply to comment #3)
> After updating to the new kernel 2.6.27.5-37.fc9.i686 the problem seems to have vanished????
> 
> I still have error messages when booting about bit rate and sometimes that the
> IP address for the wlan0 was not determined but once logged in the wlan0 is
> active and remains so.
> 
> My thanks to whomever. If anyone wishes to still work on this bug then please
> send me info about whatever additional info you need.
> 
> Namaste,
> 
> Kevin Tough
Comment 5 Bill Nottingham 2008-11-17 10:30:48 EST
OK, closing.

Note You need to log in before you can comment on or make changes to this bug.