Bug 471505 - Grid - Negotiator Tab
Grid - Negotiator Tab
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: cumin (Show other bugs)
1.1
All Linux
medium Severity high
: ---
: ---
Assigned To: messaging-bugs
Frantisek Reznicek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 20:15 EST by William Henry
Modified: 2015-11-15 19:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-21 13:24:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Henry 2008-11-13 20:15:35 EST
Description of problem:

Currently the Negotiator tab in Grid does not display anything. This is because the Condor Negotiator really doesn't have an object to interact with. Perhaps this should be deprecated.

The only reason for having it would be to view (tail) through the negotiator log or somehow parse the file based on Jobs and display a list of jobs and then examine the matchmaking for the job.  It would be cool to examine matchmaking for a job - later feature I suspect.

If Negotiator tab does get deprecated then I suggest we change Collector references to Central Manager.  Collector and Negotiator are a bit cryptic for users unless we want to expose condor implementation to the user at this level.


Thoughts?  

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthew Farrellee 2008-11-13 20:46:27 EST
I thought the Negotiator tab didn't display anything because the negotiator was running on a RHEL4 system and BZ470320

The Negotiator is the source of Limit information as well as User Priorities, which are not currently exposed, but could use an RFE.
Comment 2 William Henry 2008-11-13 22:20:09 EST
? I think that the central manger is running on north-15 RHEL 5 and has a failover on north-08 RHEL 4. Collector and Negotiator run together as Central Manager.

But I agree that if there is useful information available from the Negotiator and we can get it then I'm all for populating info in this tab.

I guess the question the is why is the Negotiator showing no data on North?
Comment 4 William Henry 2008-11-14 18:27:50 EST
Okay ... that makes sense. 

Any other thoughts?
Comment 5 Justin Ross 2009-02-23 17:39:57 EST
We have a Negotiator view now, and it's where you go to start and stop daemons, and that kind of thing.

It currently lacks stats, of which there aren't a lot, just the "MonitorSelf" stats.  I'll add a distinct bug for that.

Note You need to log in before you can comment on or make changes to this bug.