Bug 471533 - The menu"Clear Private Data" should gray out in Tools menu because it doesn't work
The menu"Clear Private Data" should gray out in Tools menu because it doesn't...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-14 01:16 EST by koka xiong
Modified: 2010-10-09 03:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-18 10:42:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the screen shot (61.28 KB, image/png)
2008-11-16 20:57 EST, koka xiong
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 465525 None None None Never

  None (edit)
Description koka xiong 2008-11-14 01:16:48 EST
Description of problem:
In firefox,click Tools-->Clear Private Data menu,no dialog pops up.

Version-Release number of selected component (if applicable):
3.0.2-1.fc9
RHEL4 3.0.4-1.el4

How reproducible:
always

Steps to Reproduce:
1.Launch firefox
2.Go to Edit->Preferences
3.In the Preferences dialog,go to Privacy tab
4.In the Private Data section,uncheck"Ask me before clearing private data",then close the dialog
5.Click Tools->Clear Private Data

Actual results:
Nothing happens,no dialog pops up

Expected results:
The menu "Clear Private Data" should gray out

Additional info:
Comment 1 Matěj Cepl 2008-11-14 11:55:00 EST
Are you able to reproduce this with the upstream binary from http://www.mozilla.com/en-US/firefox/all.html I certainly cannot reproduce it here with firefox-3.0.2-1.fc10.x86_64
Comment 2 koka xiong 2008-11-16 20:43:46 EST
Hi,Matej Cepl
I can reproduce this problem with the upstream binary from
http://www.mozilla.com/en-US/firefox/all.html.
The latest version is Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
I'll add an image to explain this problem.
Comment 3 koka xiong 2008-11-16 20:57:32 EST
Created attachment 323733 [details]
the screen shot
Comment 4 koka xiong 2008-11-16 20:59:48 EST
Please look at the screen shot.
After having set the privacy as screen shot,then go to Tools menu,click Clear Privacy Data or (Ctrl+Shift+Del).Nothing happens.
Comment 5 koka xiong 2008-11-17 00:42:35 EST
I think In the Private Data section,after uncheck "Ask me before clearing private data",the "Clear Now" button should be disabled either.
In firefox preferences dialog,select Security tab,in the Passwords section,please notice if we don't check "user a master password",the "Change Master Password" button is disabled,this is correct.
Maybe the "Clear Now" button behaviour should like the the "Change Master Password" button.
Comment 6 Matěj Cepl 2008-11-18 10:42:35 EST
We filed this bug in the upstream database (https://bugzilla.mozilla.org/show_bug.cgi?id=465525) and believe that it is more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.
Comment 7 Matěj Cepl 2010-10-07 09:53:38 EDT
There is now request for retesting in the upstream bug (https://bugzilla.mozilla.org/show_bug.cgi?id=465525#c2). Could you please respond to it either there (preferably) or at least here (if you don't want to make an account on bugzilla.mozilla.org)?

Thank you
Comment 8 koka xiong 2010-10-09 03:29:03 EDT
(In reply to comment #7)
> There is now request for retesting in the upstream bug
> (https://bugzilla.mozilla.org/show_bug.cgi?id=465525#c2). Could you please
> respond to it either there (preferably) or at least here (if you don't want to
> make an account on bugzilla.mozilla.org)?
> 
> Thank you

Hi,Matej Cepl,
I have tested on firefox 3.6.10
1.Launch firefox
2.Go to Edit->Preferences
3.In the Preferences dialog,go to Privacy tab
4.No "Ask me before clearing private data" item now, After clicking clear your recent history,it will show clear recent history dialog.
5.Click Tools->Clear Recent History,it will also show clear recent histoy dialog.

So this bug doesn't exist now.

Note You need to log in before you can comment on or make changes to this bug.