Bug 471541 - GStreamer-WARNING when launch "gstreamer-properties" [NEEDINFO]
GStreamer-WARNING when launch "gstreamer-properties"
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhythmbox (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Bastien Nocera
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-14 02:39 EST by Yolkfull Chow
Modified: 2014-06-03 08:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 08:48:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (yzhou)


Attachments (Terms of Use)

  None (edit)
Description Yolkfull Chow 2008-11-14 02:39:59 EST
Description of problem:
After launch gstreamer-properties and test video/audio output/input, will get  GStreamer-WARNING messages which tell "GLib threading system has not been initialised yet":

---------
(process:5664): GStreamer-WARNING **: The GStreamer function gst_init_get_option_group() was
        called, but the GLib threading system has not been initialised
        yet, something that must happen before any other GLib function
        is called. The application needs to be fixed so that it calls
           if (!g_thread_supported ()) g_thread_init(NULL);
        as very first thing in its main() function. Please file a bug
        against this application.
gstreamer-properties-Message: Skipping unavailable plugin 'artsdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'pulsesink'
gstreamer-properties-Message: Skipping unavailable plugin 'sdlvideosink'
gstreamer-properties-Message: Skipping unavailable plugin 'v4lmjpegsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'qcamsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'esdmon'
gstreamer-properties-Message: Skipping unavailable plugin 'pulsesrc'
gstreamer-properties-Message: Error running pipeline 'Video for Linux (v4l)': Device "/dev/video0" does not exist. [v4l_calls.c(168): gst_v4l_open (): /pipeline3/v4lsrc1]
[root@dhcp-66-70-67 Music]# 
--------------

Version-Release number of selected component (if applicable):
# rpm -qa *rhythmbox* *gstreamer*
gstreamer-plugins-base-0.10.20-3.el5
gstreamer-tools-0.10.20-3.el5
rhythmbox-0.11.6-4.el5
gstreamer-debuginfo-0.10.20-3.el5
gstreamer-0.10.20-3.el5
gstreamer-devel-0.10.20-3.el5
rhythmbox-debuginfo-0.11.6-4.el5
gstreamer-plugins-good-0.10.9-1.el5
[root@dhcp-66-70-67 Music]# 

How reproducible:
Everytime

Steps to Reproduce:
1. just launch "gstreamer-properties"
2.
3.
  
Actual results:


Expected results:
No warning/error messages should be presented in terminal.

Additional info:
Comment 1 RHEL Product and Program Management 2009-03-26 13:23:04 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 3 RHEL Product and Program Management 2014-03-07 07:41:55 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 4 RHEL Product and Program Management 2014-06-03 08:48:16 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.