Bug 471570 - "i" key doesn't show "rpm -qil" output
"i" key doesn't show "rpm -qil" output
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rpmreaper (Show other bugs)
10
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-14 06:38 EST by Adam Tkac
Modified: 2013-04-30 19:41 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.1.6-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 15:32:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Tkac 2008-11-14 06:38:18 EST
Description of problem:
"i" key shows anything on PowerPC platform

Version-Release number of selected component (if applicable):
# rpm -q rpmreaper
rpmreaper-0.1.5-1.fc10.ppc

How reproducible:
always

Steps to Reproduce:
1. run rpmreaper
2. press "i" key
  
Actual results:
nothing happens

Expected results:
rpm -qil output is presented

Additional info:
After quick investigation problem is because "char" variables are unsigned by default on PPC. When you look into http://kojipkgs.fedoraproject.org/packages/rpmreaper/0.1.5/1.fc10/data/logs/ppc/build.log there are warnings about this issue:

rpm.c: In function 'rpm_pkg_info':
rpm.c:339: warning: case label value is less than minimum value for type
rpm.c:342: warning: case label value is less than minimum value for type
rpm.c:345: warning: case label value is less than minimum value for type

When I tried declare that type as "signed char" or when I added -fsigned-char to CFLAGS "i" worked as expected.
Comment 1 Miroslav Lichvar 2008-11-14 08:16:40 EST
Fixed in upstream repository. Thanks.
Comment 2 Bug Zapper 2008-11-26 00:22:04 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Fedora Update System 2009-04-02 08:29:52 EDT
rpmreaper-0.1.6-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/rpmreaper-0.1.6-1.fc9
Comment 4 Fedora Update System 2009-04-02 08:30:42 EDT
rpmreaper-0.1.6-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/rpmreaper-0.1.6-1.fc10
Comment 5 Fedora Update System 2009-04-02 22:25:36 EDT
rpmreaper-0.1.6-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rpmreaper'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3301
Comment 6 Fedora Update System 2009-04-13 15:31:56 EDT
rpmreaper-0.1.6-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2009-04-13 15:45:35 EDT
rpmreaper-0.1.6-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.