Bug 471573 - OmegaT miss a dependency on htmlparser
OmegaT miss a dependency on htmlparser
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: OmegaT (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ismael Olea
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-14 07:03 EST by Oron Peled
Modified: 2008-11-22 11:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-21 05:55:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oron Peled 2008-11-14 07:03:25 EST
Description of problem: 
 * The htmlparser package is needed by OmegaT (its inclusion in
   Fedora was even marked as a blocker for OmegaT approval).
 * However, OmegaT package does not specify it as a dependency.
 * Therefore, it's easy to install a non-functioning OmegaT.

Version-Release number of selected component (if applicable):
The bug was first observed on F8.

However, testing on a fully updated F10 pre-release installation:

$ yum deplist OmegaT
...
Finding dependencies:
package: OmegaT.noarch 1.7.3_03-5.fc10
  dependency: java
   provider: java-1.6.0-openjdk.i386 1:1.6.0.0-2b12.fc10
   provider: java-1.5.0-gcj.i386 1.5.0.0-22.fc10
   provider: java-1.6.0-openjdk.i386 1:1.6.0.0-2b12.fc10
   provider: java-1.5.0-gcj.i386 1.5.0.0-22.fc10
  dependency: /bin/sh
   provider: bash.i386 3.2-29.fc10
   provider: bash.i386 3.2-29.fc10
  dependency: vldocking
   provider: vldocking.noarch 2.0.6e-3.fc10
   provider: vldocking.noarch 2.0.6e-3.fc10

Steps to Reproduce:
1. Install OmegaT without htmlparser (or remove htmlparser).
2. Running OmegaT and trying to read files causes an exception
   due to missing htmlparser:
     Exception in thread "Command thread" java.lang.NoClassDefFoundError: 
       org/htmlparser/util/ParserException
     ...
3. Running yum install htmlparser solve this problem of course.
  
Expected results:
Have htmlparser as a dependency of OmegaT
Comment 1 Ismael Olea 2008-11-19 15:36:29 EST
Thanks for the report. Fixing it.
Comment 2 Fedora Update System 2008-11-19 16:08:47 EST
OmegaT-1.7.3_03-6.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/OmegaT-1.7.3_03-6.fc9
Comment 3 Fedora Update System 2008-11-19 16:09:42 EST
OmegaT-1.7.3_03-6.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/OmegaT-1.7.3_03-6.fc10
Comment 4 Fedora Update System 2008-11-19 16:24:44 EST
OmegaT-1.7.3_03-6.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/OmegaT-1.7.3_03-6.fc8
Comment 5 Fedora Update System 2008-11-21 05:55:07 EST
OmegaT-1.7.3_03-6.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2008-11-21 05:59:29 EST
OmegaT-1.7.3_03-6.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2008-11-22 11:44:16 EST
OmegaT-1.7.3_03-6.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.