Bug 471624 - Picture screensaver does not use all pictures [NEEDINFO]
Picture screensaver does not use all pictures
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-screensaver (Show other bugs)
5.2
i386 Linux
medium Severity low
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-14 13:03 EST by Gunnar Hellekson
Modified: 2014-06-02 09:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:03:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (ghelleks)


Attachments (Terms of Use)

  None (edit)
Description Gunnar Hellekson 2008-11-14 13:03:48 EST
Description of problem:

"Picture folder" screensaver does not use all images in the $HOME/Pictures directory.

Version-Release number of selected component (if applicable):

gnome-screensaver-2.16.1-8.el5

How reproducible:

Completely.

Steps to Reproduce:
1. Add a number of images to the $HOME/Pictures folder
2. Enable the screensaver
3. Watch a subset of those photos appear in the screensaver
  
Actual results:

Not all of the images are displayed.

Expected results:

If some of the images are invalid, the program should announce or log the fact that some photos were skipped, and for what reason.

Additional info:

Using the same set of images, a different subset of those images appeared on different machines.
Comment 1 Ray Strode [halfline] 2014-02-27 09:25:09 EST
I think we just need a g_random_set_seed (time (NULL)) call added to srvers/gste-slideshow.c or so.
Comment 2 RHEL Product and Program Management 2014-03-07 07:40:03 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 3 RHEL Product and Program Management 2014-06-02 09:03:04 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.