Bug 471725 - Use metalink URLs in fedora-release repos. for Fedora 11?
Use metalink URLs in fedora-release repos. for Fedora 11?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-15 01:25 EST by James Antill
Modified: 2013-01-09 23:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-07 18:54:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2008-11-15 01:25:20 EST
Description of problem:

 One of the new features for Fedora 10 is the MirrorManager and yum both support metalink data for mirrors, alas. it doesn't look like anyone ever filed the BZ against fedora-release to get the configuration for the Fedora 10 repos changed. So here goes (better late than never).
 Quick summary:

 Pros:

. 100% backwards compatible and a small change, just adds a "metalink = <url>" line to each repo. which overrides the mirrolist on newer yums.

. drastically reduces the possibility of attacking Fedora boxes via. mirror hacking, as you'd need to intercept the metalink data or the repomd.xml needs to conform to the hashes in the metalink data.

 Cons:

. Not tested in any of the Fedora Betas *sigh*

. Now ~2 weeks from Fedora 10 GA release, so any change is kinda bad.

. If MirrorManager gives out "old metalink data", yum will refuse to use any of the mirrors (AIUI this is now a monitored infrastructure service though).

. mirror data is now tied to all the other metadata in yum. This means that while before mirrorlists were checked at most once a day and the rest of the metadata at most once every 1.5hrs ... now the metalink data is checked at most once every 1.5hrs.
 I'm not sure that this matters, or that we could foresee any problems if it turns out to be until we have a release day with metalink turned on anyway ... but I put it in for completness.
Comment 1 Bug Zapper 2008-11-26 00:25:59 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 James Antill 2008-12-20 14:35:16 EST
 Jesse ... can we do this after the holidays?
 Also I'm not sure if Matt wants the URLs to be http or https ... matt?
Comment 3 Jesse Keating 2008-12-20 14:51:36 EST
I thought we decided to not do this for F10 and do it for F11 instead?
Comment 4 James Antill 2008-12-21 02:32:24 EST
I swear I'd changed the release, which made it more obvious what I was saying.

 Anyway, I meant can you change it "soon" in current rawhide (anytime before the first alpha/beta is fine).
Comment 5 Jesse Keating 2009-01-20 19:44:50 EST
Just getting back to this again, what is the syntax for the metalink url?
Comment 6 Ant Bryan 2009-01-20 19:55:02 EST
(In reply to comment #5)
> Just getting back to this again, what is the syntax for the metalink url?

http://mirrors.fedoraproject.org/metalink?path=pub/fedora/linux/releases/10/Fedora/i386/iso/Fedora-10-i386-DVD.iso

It could be handy if MM could return a file named "filename.metalink" instead of "metalink".
Comment 7 James Antill 2009-01-21 01:48:54 EST
 My rawhide is:

[rawhide]
name=Fedora - Rawhide
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/development/$basearch/os/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide&arch=$basearch
metalink=https://mirrors.fedoraproject.org/metalink?repo=rawhide&arch=$basearch
enabled=0
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-test-$basearch file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

...keeping mirrorlist in there is fine, for backwards compat., as yum will ignore it if it sees a metalink config. ... or remove it, whichever :).
Comment 8 Jesse Keating 2009-01-21 18:55:54 EST
Changes made, headed toward rawhide (and alpha).
Comment 9 Bug Zapper 2009-06-09 05:53:12 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.