Bug 47173 - rpm 4.0.2 dies with bus error when installing kernel-2.2.19-6.2.7.sparc.rpm
rpm 4.0.2 dies with bus error when installing kernel-2.2.19-6.2.7.sparc.rpm
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-03 16:01 EDT by David Juran
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-09 13:50:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
core that is dumped by rpm (628.00 KB, application/octet-stream)
2001-07-03 16:04 EDT, David Juran
no flags Details

  None (edit)
Description David Juran 2001-07-03 16:01:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12smp i686)

Description of problem:
rpm dies with bus error when trying to upgrade or install the new
kernel-2.2.19-6.2.7.sparc.rpm

How reproducible:
Always

Steps to Reproduce:
1.  rpm -i -vv kernel-2.2.19-6.2.7.sparc.rpm

	

Actual Results:  [root@simplex download]# rpm -i -vv
kernel-2.2.19-6.2.7.sparc.rpm 
D: counting packages to install
D: found 1 packages
D: looking for packages to download
D: retrieved 0 packages
D: Expected size:      2759112 = lead(96)+sigs(149)+pad(3)+data(2758864)
D:   Actual size:      2759112
D: opening db file        /var/lib/rpm/packages.rpm mode 0x202
D: found 0 source and 1 binary packages
D: opening db file        /var/lib/rpm/Depends.idx mode 0x202
D: opening db file        /var/lib/rpm/providesindex.rpm mode 0x202
D: opening db file        /var/lib/rpm/nameindex.rpm mode 0x202
D:   YES    A initscripts = 5.49-1      B initscripts >= 3.64
D:  Requires: initscripts >= 3.64                           YES (db
package)
D:  Requires: modutils                                      YES (db
package)
D:  Requires: fileutils                                     YES (db
package)
D:  Requires: mktemp                                        YES (db
provides)
D: opening db file        /var/lib/rpm/fileindex.rpm mode 0x202
D:  Requires: /bin/sh                                       YES (db files)
D:  Requires: R /bin/sh                                     YES (cached)
D:  Requires: R /bin/sh                                     YES (cached)
D:   NO     A rpmlib(PayloadFilesHavePrefix) <= 4.0-1   B
rpmlib(VersionedDependencies) = 3.0.3-1
D:   NO     A rpmlib(PayloadFilesHavePrefix) <= 4.0-1   B
rpmlib(CompressedFileNames) = 3.0.4-1
D:   NO     A rpmlib(PayloadFilesHavePrefix) <= 4.0-1   B
rpmlib(PayloadIsBzip2) = 3.0.5-1
D:   YES    A rpmlib(PayloadFilesHavePrefix) <= 4.0-1   B
rpmlib(PayloadFilesHavePrefix) = 4.0-1
D:  Requires: rpmlib(PayloadFilesHavePrefix) <= 4.0-1       YES (rpmlib
provides)
D:   NO     A mount = 2.10r-0.6.x       B mount < 2.10r
D:   NO     A mount = 2.10r-0.6.x       B mount < 2.10r
D: Conflicts: mount < 2.10r                                 NO
D: Conflicts: nfs-utils < 0.3.1                             NO
D: opening db file        /var/lib/rpm/conflictsindex.rpm mode 0x202
D:   NO     A kernel = 2.2.19-6.2.7     B kernel <= 2.2
D:   NO     A kernel = 2.2.19-6.2.1     B kernel <= 2.2
D:   NO     A kernel = 2.2.17-14        B kernel <= 2.2
D:   NO     A kernel = 2.2.19-6.2.1     B kernel <= 2.2
D: Conflicts: kernel <= 2.2                                 NO
D: Conflicts: C kernel <= 2.2                               NO  (cached)
D: ========== recording tsort relations
D: ========== tsorting packages
D:     0 (1,1) kernel-2.2.19-6.2.7
D: ========== successors only (presentation order)
D: installing binary packages
D: getting list of mounted filesystems
Bus error (core dumped)
Comment 1 David Juran 2001-07-03 16:04:06 EDT
Created attachment 22611 [details]
core that is dumped by rpm
Comment 2 Jeff Johnson 2001-12-09 13:29:11 EST
Does this problem still occur with rpm-4.0.3 final
from
	ftp://ftp/pub/rpm/dist/rpm-4.0.x
Yes, there are packages for Rea Hat 6x there.
Comment 3 David Juran 2001-12-09 13:50:50 EST
Hmmm, running rpm --rebuilddb solved the problem, so I can no longer reproduce
it, but if you want me to upgrade or test something else, just tell me (-:

Note You need to log in before you can comment on or make changes to this bug.